Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

google search problem with opera 12.17

  • BTW milija's suggested temporary fix (edit site preferences) totally WORKS.

    Not for me. When I start a search, the screen appears totally disordered.

  • "BTW milija's suggested temporary fix (edit site preferences) totally WORKS."

    Not totaly, the "search prediction" stops working when you mask it as Explorer.

  • Found a fix for this!

    Go to "opera:config : User Prefs" and copy this line:

    Mozilla/5.0 (Windows NT 5.1; rv:31.0) Gecko/20100101 Firefox/31.0

    to the "Custom User-Agent" field.
    Don't forget to click "Save".

  • To get arrow buttons to render correctly, add this to user style for www.google.com:

    .action-menu {
        display: inline-block !important;
    }
  • Apparently this is not an Opera problem but a Google one, it is reported elsewhere by people using other browsers as well.

  • atharip, may know how to add the user style for www.google.com:

  • Guys, the problem is obvious.... Google changed their layout to all non-Chrome browsers because they want everyone to download their Chrome.

    It's been happening to all browsers, not just Opera.

    Look what happens when you're on the main Google.com page, it pops a little window at the right upper corner saying "Download Chrome".

    BTW, milija's solution works.

  • Thanks mxxxw, your solution works perfectly for me.

  • MXXXW - this WORK GREAT (windows xp SP3, opera 12.17 )

    I have normal google search page and
    now again working " similar image search " extension

    THANKS very much

  • MXXXW, your fix works! Fine!

    I wonder how/where you have found that solution (it's not simple either).

  • Go to "opera:config : User Prefs" and copy this line:

    This solution will mask your user-agent for all sites, it can produce more bugs than it fixes!
    The only perfect solution is to pat#ch Opera. Open opera.dll with any hex editor, search for a string "Firefox", replace "Gecko/20100101" to "Gecko/20140101" and "Firefox/4.0" to "Firefox/250". Now you can use "Identify As Firefox" only on selected sites.

  • Tamers' fix works fine, with the upshot that mask as ff now masks as a recent browser which is nice. Thx also to Atharip, those arrows looked crappy like that, much better.

  • Using patched opera.dll + masking User-Agent string as Firefox (the new version of this) for google.com (via Site preferences) is the most flexible solution.

    Also, i'll recommend to install Antibrowsersniffer extension (for Opera 12) to mask Opera via JavaScript/Navigator. Install Antibrowsersniffer (for Opera/Presto): https://addons.opera.com/ru/extensions/details/antibrowsniffer/?display=en

  • Nice thought about opera.dll, though I changed mine to the lowest possible number, 100. Also, since the actual Firefox's string still has "20100101," I don't think the date matters.

    While you're at it, the same can be done for IE's user agent (along with the change to Trident 7.0).

    For anyone wanting the old underlined results, too:

    #rcnt a { 
    text-decoration : underline !important
    }
  • Can anyone tell me where exactly to add the below lines,i am noob .

    action-menu {
    display: inline-block !important;
    }

  • Hy! I've been having the same problem, currently I run Opera 12.17. I searched far and wide but i could not find a solution. Then it hit me ... I loaded google start page and did the following: Hit F12 -> Edit Site Preferences -> Network -> Browser Identification -> Make as Internet Explorer . For me it worked beautifully, I hope it will help you to. Good Luck! 🙂

  • Then it hit me ... I loaded google start page and did the following: Hit F12 -> Edit Site Preferences -> Network -> Browser Identification -> Make as Internet Explorer

    This is poorly working solution.

    Full instruction for a full working solution:
    http://www.reddit.com/r/operabrowser/comments/2qfrac/opera_12_versus_google_search_how_to_fix/

  • @stng, good find! It works well on 12.14 here - at least, it will until Google decides to mess with their site code again. The problems with globally setting the user agent string to something other than old Opera is that some sites that sniff browsers actually do create code for specific features available only in particular browsers and then deliver custom site code tailored for those specific browser models. In such cases, that code can break if viewed in a different browser lacking such features or implementing them differently. The ability to define 'site preferences' within the browser itself and via the override.ini file is one of the very most valuable features of Presto Opera, and significantly under-rated by many - sadly.

  • Mask as Internet Explorer. You can set the preference only for the google site if you like. (right click, Edit Site Preferences, network, Mask as Internet Explorer)

Log in to reply