Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Brak polskich znaków tylko na stronie www.facebook.com

  • Witam ewidentnie mam problem z polskimi z niektórymi polskimi znakami tylko na stronie Facebook.com. Na innych stronach bez problemu są wszystkie polskie znaki ą, ę, ś ć ń ź.
    Patrzyłem na ustawienia w opcjach języka jest ustawione na polski. Mimo to nie ma polskich znaków.
    Ktoś miał może taki problem?
    Poniżej screen z przykładowego posta.

    obraz_2020-11-13_231250.png

  • Podbijam! Post jak widzę - sprzed miesiąca. Pojawił mi się identyczny problem.
    Jeszcze zrobię reinstalkę i zobaczymy czy pomoże.

    Edit: Nie pomogło.

  • @stlsht u mnie też reinstalacja nie pomogła 😞

  • @rafaellok nie znam się na kodowaniu, ale nawet intuicyjnie widać, że problem jest dosyć dziwaczny. Jest to z pewnością jakiś bug w komunikacji między Operą (a także OperąGX, bo sprawdziłem) a Facebookiem/Messengerem (tylko tam mam problem) - ale dotyczy on jak widać bardzo niewielkiej ilości osób, bo nie widziałem innych zgłoszeń niż nasze. Czyli może być to powodowane przez skrypty z innych aplikacji, ale to dziwne, bo ja nie kojarzę, żeby jakaś aplikacja z windowsa miała wpływać na przeglądarkę, a co dopiero na konkretny adres internetowy.

    Najdziwniejsze jest samo zawężenie problemu - czyli błąd wyświetlania konkretnych glifów unicode (nawet nie wszystkich! - np. takie "ą" wyświetla mi normalnie) na stronie konkretnego portalu i w dodatku tylko w dwóch zarejestrowanych przypadkach - gdzie drugi pojawił się po miesiącu od Twojego zgłoszenia (!).

    Ja mam w takich kwestiach nerwicę - dopóki nie rozwiążę tej zagadki to nie mogę pracować, zajmuje mi to głowę. Liczę więc na wskazówki od bardziej doświadczonych użytkowników.

    To może nie mieć znaczenia, ale żeby znaleźć jakieś elementy wspólne to powiem tylko, że tuż przed wystąpieniem problemu pracowałem z pakietem Adobe, Windows Home, od kilku dni zaktualizowany do wersji 10.0.18363. Do powierzchownych porządków używam Glary Utilities.

    W kontakcie

    EDIT: Rozszerzenie analizujące glify Unicode w ogóle nie widzi problemu - gdy zaznaczam i sprawdzam tę "dziwną literkę" to rozpoznaje ją właściwie. Czyli, jeśli dobrze kombinuję, nie jest to kwestia informacji od FB tylko jakiejś zmiennej nakładanej przez Operę już PO kodowaniu.

  • @rafaellok dobra, mam to!

    Problem spowodowany jest przez font Segoe UI Historic, który jest standardowym fontem Windowsa, który Facebook implementuje u siebie. Nie jestem jeszcze w stanie podać powodu dla którego ten font jednym się rozjeżdża, a innym nie. Ale to nie jest w tym momencie najistotniejsze.

    Przede wszystkim znalazłem wątek na forum Microsoftu na którym również zwracana jest uwaga na fakt, że ten font sypie się kompletnie randomowo i nie wiadomo o co w ogóle chodzi: https://cutt.ly/EhPl8Z5

    Tak czy inaczej, rozwiązania problemu są dwa - pierwszy to próba podmiany fontu systemowego w rejestrze, o czym mowa w powyższym wątku. Jest sporo sposobów żeby to zrobić, np. za pomocą programu Winaero Tweaker, można też znaleźć w sieci tutoriale które podpowiadają jak zrobić to "ręcznie".

    Druga opcja jest o wiele prostsza i już ją wypróbowałem - działa.
    Trzeba zainstalować rozszerzenie ze sklepu Chrome, które nazywa się Fontfully i pozwala zmienić typeface na wybranych stronach. Ja na FB i Messengerze zmieniłem sobie na Roboto i problem zniknął: https://cutt.ly/ghPccji
    Jest kilka innych rozszerzeń zmieniających fonty, ale nie wszystkie działają z Operą, więc trzeba potestować.

    Na pytanie dlaczego ten font krzaczy się na niektórych systemach i od czego jest to zależne - pozostaje zagadką.

    Pozdrawiam serdecznie!

    Edit:

    Działają jeszcze następujące rozszerzenia:
    Change Webpage Fonts - https://cutt.ly/dhPcyn8
    Re-font - https://cutt.ly/qhPxaHl

  • Faktycznie jest tak jak napisałeś wyżej problem jest z fontem. Zainstalowanie Fontfully i zmiana na Roboto rozwiązuje ten dość dziwaczny problem. Myślę, że chyba to najlepsze rozwiązanie na chwilę obecną. Dzięki za info.
    Pozdrawiam.

  • Jeszcze jeden sposób

    Może ktoś kiedyś tu trafi z podobnym problemem.
    Ja osobiście miałem kłopot z tymi rozszerzeniami o których pisaliśmy wyżej - albo trzeba było je uruchamiać za każdym razem po uruchomieniu Opery, albo zmiany nie działały w Messengerze z paska bocznego. Postanowiłem znaleźć coś bardziej stabilnego.

    Te addony się krzaczyły, bo były przeznaczone na Chrome. Poszukałem więc rozwiązania w rozszerzeniach Opery. I znalazłem to:

    FreeStyler - narzędzie dzięki któremu można zmienić CSS na każdej stronie. Na stronie https://freestyler.ws/ można znaleźć wiele styli które można implementować jednym kliknięciem (np. zmienić wygląd Facebooka na czarny itp.). Polecam poczytać i się tam rozejrzeć - można znaleźć fajne rzeczy.

    Ja nie umiem w CSS, ale sugerując się innymi stylami zrobiłem specjalnie taki, który zmienia font na FB i w Messengerze na Roboto (zmiana zachodzi rownież w pasku bocznym). Tutaj link: bit.ly/3nk10hT

    A tutaj link do rozszerzenia:
    https://addons.opera.com/pl/extensions/details/freestyler/

    Pzdr.

  • @stlsht Dzięki za pomoc! W końcu po pół roku mogę korzystać z kompa, bo wcześniej - przez te problemy z czcionką - się nie dało 😞