Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 68.0.3618.173: error compiling any package

  • Hi,
    after installing last Opera Update to the last release I always get a opera-stable error when I install any Linux package.

    sudo dpkg --configure -a
    Configurando opera-stable (68.0.3618.173) ...
    dpkg: error al procesar el paquete opera-stable (--configure):
     instalado opera-stable paquete post-installation guión el subproceso devolvió un error con estado de salida 1
    Se encontraron errores al procesar:
     opera-stable
    
    

    When I install/reinstall Opera I get the same error in opera-stable:

    in opera-stable
    Leyendo lista de paquetes... Hecho
    Creando árbol de dependencias       
    Leyendo la información de estado... Hecho
    Paquetes recomendados:
      pepperflashplugin-nonfree
    Se instalarán los siguientes paquetes NUEVOS:
      opera-stable
    0 actualizados, 1 nuevos se instalarán, 0 para eliminar y 1 no actualizados.
    Se necesita descargar 0 B/67,5 MB de archivos.
    Se utilizarán 224 MB de espacio de disco adicional después de esta operación.
    Preconfigurando paquetes ...
    Seleccionando el paquete opera-stable previamente no seleccionado.
    (Leyendo la base de datos ... 347476 ficheros o directorios instalados actualmente.)
    Preparando para desempaquetar .../opera-stable_68.0.3618.173_amd64.deb ...
    Desempaquetando opera-stable (68.0.3618.173) ...
    Configurando opera-stable (68.0.3618.173) ...
    dpkg: error al procesar el paquete opera-stable (--configure):
     instalado opera-stable paquete post-installation guión el subproceso devolvió un error con estado de salida 1
    Procesando disparadores para gnome-menus (3.13.3-11ubuntu1.1) ...
    Procesando disparadores para hicolor-icon-theme (0.17-2) ...
    Procesando disparadores para mime-support (3.60ubuntu1) ...
    Procesando disparadores para desktop-file-utils (0.23+linuxmint6) ...
    Procesando disparadores para menu (2.1.47ubuntu2.1) ...
    Procesando disparadores para shared-mime-info (1.9-2) ...
    Se encontraron errores al procesar:
     opera-stable
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    
    

    I have reinstall opera-stable (from .deb package and via wget) several times with the same result. It works but I always get the same error when I install/upgrade any Linux Package.
    I even deleted everything related with Opera and reinstall again from scatch, but nothing solve it.
    The only thing affecting Opera installation was the subtitution of the file libffmpeg.so in the path /usr/lib/x86_64-linux-gnu/opera from the one coming in chromium-ffmpeg-extras because I couldn't play Videos in Opera. But reinstalling Opera return it to the Opera libffmpeg.so file, so I don't think it is related with the issue.
    I will appreciate any help.

  • Hi @lixbeto, you can try to call apt-get -f install to fix the issue with Opera's installation. If this doesn't help, uninstall Opera, and try to install it from the .deb as follows dpkg -i --force-all name.deb.
    Regarding the libffmpeg.so, to avoid it to be overwritten by Opera's update, don't copy it over the Opera's one, but go to Opera's install root, add "lib_extra" subfolder, and copy the lib there.

  • Thank you l33t4opera for your help.
    Yes, I tryed the installation with apt-get -f install, but it didn't solve the issue.
    I also installed opera with the deb forcing the installation, but still get the error with the opera-stable package.
    Good to know that is better don't overwrite the libffmpeg.so file I will try it. Actually, I didn't overwrite it, I just renamed the original file, so I could come back to it if it were necessary, but the one from the chromium-ffmpeg-extra or the original one didn't reverse this issue, so I am not sure this thing is related with the problem.
    My perception is it is related just the the last Opera update. I can't test it installing previous version because I don't find it, I don't know if exists some kind of archive with older versions.

  • @lixbeto By overwrite I mean to not replace the lib in Opera's root, to avoid it to be overwritten by the next update.
    What is your Linux distro and version?
    What if you uninstall the Opera, does this solve the problem with the packages manager? If so, try to unpack the files to the installation root from the .deb, and you should be fine as you says.
    By the way: there's already the latest Opera stable 69.0.3686.36.
    You can find previous versions of stable here.

  • @l33t4opera Hi I am installing Opera stable 69.0.3686.36 on Linux Mint 20 which is based on Ubuntu 20.04 from the .deb file and I get this error:

    Selecting previously unselected package opera-stable.
    (Reading database ... 
    (Reading database ... 5%%
    (Reading database ... 10%%
    (Reading database ... 15%%
    (Reading database ... 20%%
    (Reading database ... 25%%
    (Reading database ... 30%%
    (Reading database ... 35%%
    (Reading database ... 40%%
    (Reading database ... 45%%
    (Reading database ... 50%%
    (Reading database ... 55%%
    (Reading database ... 60%%
    (Reading database ... 65%%
    (Reading database ... 70%%
    (Reading database ... 75%%
    (Reading database ... 80%%
    (Reading database ... 85%%
    (Reading database ... 90%%
    (Reading database ... 95%%
    (Reading database ... 100%%
    (Reading database ... 413927 files and directories currently installed.)
    Preparing to unpack .../opera-stable_69.0.3686.36_amd64.deb ...
    Unpacking opera-stable (69.0.3686.36) ...
    Setting up opera-stable (69.0.3686.36) ...
    dpkg: error processing package opera-stable (--install):
     installed opera-stable package post-installation script subprocess returned error exit status 1
    Processing triggers for desktop-file-utils (0.24+linuxmint1) ...
    Processing triggers for mime-support (3.64ubuntu1) ...
    Processing triggers for hicolor-icon-theme (0.17-2) ...
    Processing triggers for shared-mime-info (1.15-1) ...
    Errors were encountered while processing:
     opera-stable
    
  • I am using Linux Mint 19.2 Cinnamon.
    Uninstalling Opera didn't solve the problem, I did it several times, even I removed any file named opera or opera-stable before install it again.
    As I said, Opera is working for me, that is not the issue, but installing any update in Linux Mint of any app gives me this error, which is annoying but I don't know if it has any impact in the app's update.
    Looks like, I am not the only one with this issue and apparently it also happens with the newest version.

  • By the way, thank you very much for the Opera repository.
    I am going to test with previous versions.

  • Nope, too bad. Installing some other Opera previous version didn't do the trick. Still with the same error.

  • Apparently with this workaround solved the issue:

    sudo mv /var/lib/dpkg/info /var/lib/dpkg/info_old     
    sudo mkdir /var/lib/dpkg/info             
    sudo apt-get update && sudo apt-get -f install
    sudo mv /var/lib/dpkg/info/* /var/lib/dpkg/info_old    
    sudo rm -rf /var/lib/dpkg/info             
    sudo mv /var/lib/dpkg/info_old /var/lib/dpkg/info

    I have installed some other application to check and now it doesn't show that message.
    I will test again with any update as long as some is available.

Log in to reply