Opera does not connect to local IPs/Domains with OffRoad/Turbo mode active

  • With Turbo active Opera browser seems to ignore IPs in local networks.
    I cant connect to local webserver 192.168.10.100 on my LAN with Turbo active.
    But the IP is reachable with Opera and Turbo off.

    The Browser should know, that 192.168.. is a local network and can not be reached by a external proxy service like Turbo!

    An other problem are local hostanames like fritzbox.local or router2.intern, these are not reachable with Opera + Turbo. But these hostnames are resolvable by PCs and other browsers.
    Opera browser should know thesee hostnames resolve to local IPs and therefore the external Turbo servers should not be used.

    This seems to be a Opera bug.

    Reported as Bug: DNA-23918

  • Depends on what port is forwarded as open by the router and detected on default browser. For example a public router from my area forward port 8080 open, same port is on mini side and localhost will show the login page.

  • Depends on what port is forwarded as open by the router and detected on default browser

    I dont want to use Turbo with internal IPs, thats a nonsense.

    Opera should skip the Turboproxy for local networks.

  • In this case you request a browser 'fallback' (unk term for this feature) and can't work in this way as network switch. With turbo off it's more easy and the same crossnetwork standard is applied for both Opera Mini and Opera Mobile so no problem there.

  • OK, the real fix is: Do not use Turbo or use Brain 1.0 to inspect Opera seeting for Turbo and sweitch off if enabled.

    @dirgas In this case you request a browser 'fallback'

    Yes, you may call it fallback. I call it failsafe ;)

    Local IPs are wellknown by IANA. See https://tools.ietf.org/html/rfc1918
    A internal lookup table should be in Opera Stable, to disable Turbo for private IPs.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.