Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera always in foreground

  • [Mod edit: off-topic rant and all caps comment removed]

  • Bugger, can't edit my previous post!
    I've just checked my version, and it version 23! Opera updated from 22 to 23 without my knowledge or permission! That is why I am having taskbar problems. How can I revert back to O22??!!

    http://www.opera.com/download/guide/?os=windows&ver=22.0.1471.70&local=y

    Here's the direct download link for the previous version of Opera 22. Just bear in mind that it seems like the extensions for Opera 22 no longer work. So you won't be able to use the search bar on the speed dial page. But that's a small gripe for me because I mainly use the actual google page anyway. Just make sure to allow the browser to access the internet, but block the autoupdater from accessing the internet through your firewall or it will just update to Opera 23 again. Why on earth Opera wouldn't put a way to turn off automatic updates in the settings I will never know. Such a basic option to overlook. Anyway, hope this helps for the meantime until Opera can release an update that fixes the taskbar blocking issue.

  • I have exactly the same problem as the other users describe above. no taskbar when Opera is open.

  • Hello guys, I've found a workaround for this bug in windows XP though it may work on windows 7 also, but there's a difference which I'll explain at the end.

    Instead of having the Opera windows maximized, choose "restore" and then you resize manually the window to the full size of your monitor except the bottom one, there you leave it half an inch away from it (it can be less than that, try smaller sizes but never full at the bottom 'cause then it won't work).

    The issue with windows 7 is that it automatically maximizes a program window when you try to change its shape closer to the size of the display's area, if you can avoid this congratulations then, but I don't have the time right now to experiment on W7, so if one of you try this please let us know if it worked or not.

    I hope I've helped to at least one of you.

  • First: Yes, the Windows button works. But I don't want to use the button every time I want to change the window, that's a PITA!

    And I also don't want to try to resize opera manually, so that it will maybe fit or maybe will automatically maximize...
    It is not possible that the Opera team is not able to fix this bug, it worked for 22 versions before.

    Will anyone of the programmers team will read this forum? Maybe we all should write emails ..

  • Same problem here, they should fix it soon. Such dumb issue.

  • Please, everybody star this issue to draw devs attention to it and get it finally fixed for good.

  • Hey guys I also have the same problem. Start bar can not be view or accessed if you have auto hide on and Opera Browser is maximized...

    Looks like I will be installing the latest version of v22 because v23 has this bug and no setting to fix it.

  • Simply restore and resize the window like Juarez explained, this bug is very easy to avoid...

  • please fix this bug, the "juarez-solution" is not really a solution...

  • I agree that the bug should be fixed, but Juarez's suggestion is a great temporary solution and you can't deny that!

  • Or you could just install Opera 22 and avoid the whole thing altogether until an update that fixes the issue is released.

  • Or you can stay in the latest version (isn't that preferable?) and use the workaround!

  • Same problem here (version 23.0.1522.60).
    Please fix.
    Very annoying.

  • Or you can stay in the latest version (isn't that preferable?) and use the workaround!

    Um, No. I am a multitasker, hence I often use multiple windows. Some in full screen, some in smaller windows. Arranged in the way I need them to at the time I'm using them. I only want to set my window sizes once. So once I set my window sizes I want to switch between them quickly. I can't do that if I have to constantly resize my windows manually just so I can have my full screen windows not block the taskbar. So no, it's not preferable to use the latest version and have to constantly fiddle with the window sizes every time I open a new window just so I can say "OOOH I'M RUNNING THE "LATEST" VERSION!". It's easier for me to just revert back "one" version and use that one until the next update comes out. That way I don't have to constantly fiddle with window sizes. And I don't have to worry about my browser blocking my damn taskbar. Opera 22 worked perfectly. Opera 23 does not. Hence, why it's preferable for me to use Opera 22 until Opera releases an update that fixes this issue.

  • yeah thats right i agree the opera 22 working perfectly but the last update opera 23 ITS NOT GOOD..........PLEASE FIX IT OR I USE ANOTHER BROWSER..BUT I LIKE OPERA AND....FIX THAT GOD DAM WHAT IS GOING ON...AND VERY BIG PROBLEM IS AUTOUPDATE ,NOWHERE IS THE QUESTION FOR USING UPDATE ..ONLY AUTOMATICLY..THAT THE SECOND PROBLEM...FIX IT..LAST OPERA 23 IS NOT WORK GOOD LIKE OPERA 22..............................................FIX THAT

  • But you only have to resize the Opera window once...

  • But you only have to resize the Opera window once...

    No, you don't. It's called snap. Move the window all the way to the right/left and it snaps to half screen. Move the window to the top, it snaps to full screen. Drag anywhere else and it snaps to the user predefined size. Usually I have that size set to quarter screen. The method you're promoting requires me to lose my quarter screen snap and set it to almost full screen (without actually being full screen) just so I can get my taskbar to not be blocked by the browser. Which means that any time I want a mix of full screen windows and quarter size windows, I have to manually resize each window, every time, for what I need it to be. Which means, constant fiddling that only proves to be annoying. So NO, you don't have to resize it only once using the method your pushing. You have to do it constantly. So again, NO, your method is not preferable. For me, backdating just "ONE" update fixes the issue and means I don't have to deal with all the hassles and annoyance inherent to the "Workaround" you're "PEDDLING". I am not going to be at any risk using one version older than current.

    Why don't you ask any number of people who know windows inside and out if it's preferable to use windows auto-update just so they can say they are on the latest version of windows. If you knew anything about windows update history, you would know it's not always a good thing. There has been a lot of instances where auto-updates caused far more damage than good. Thanks to Windows, there's now a term in the industry for it. They're called Rogue Updates. That's why most people in the IT field, turn off auto-update in windows and only do periodic bulk updates when they know there are no current issues with any of the windows updates.

  • Same problem here. Downgrading in a few minutes to v22. It's very annoying not to be able to go outside windows without using the windows button. I really liked the new heart menu in v23, ah well, I'll wait.

    Edit: Pfff, downgrading isn't a fine solution either. It will upgrade automatically to v23, and meanwhile your search engines and profile is messed up. Can't find the disable auto update, must be somewhere. Grr...

    Edit2: "C:\Program Files (x86)\OperaN\launcher.exe" --disable-update should work, but it doen'st. I'm done here, will use chrome for a while until it's fixed.

  • Same problem here. Downgrading in a few minutes to v22. It's very annoying not to be able to go outside windows without using the windows button. I really liked the new heart menu in v23, ah well, I'll wait.
    Edit: Pfff, downgrading isn't a fine solution either. It will upgrade automatically to v23, and meanwhile your search engines and profile is messed up. Can't find the disable auto update, must be somewhere. Grr...
    Edit2: "C:\Program Files (x86)\OperaN\launcher.exe" --disable-update should work, but it doen'st. I'm done here, will use chrome for a while until it's fixed.

    Yeah, I knew about that as well. I hightlighted the issue for the search extensions not working in 22 because they've updated them for 23. Doesn't bother me as I have the actual google page as my home page. As for the updater, just block it with your firewall. Allow the Opera Browser to access the internet, but block the opera updater and it will prevent it from updating.

Log in to reply