Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Opera 67.0.3575.31 freezing soon after startup

  • After upgrading to the version mentioned in the title, when I start Opera, it hangs after a few seconds. Tried disabling extensions, and starting without sandbox. Tried with different versions of libffmpeg.so, as it used to go wrong sometimes. None helped. I don't want to reinstall it, because I have data in my extensions that I don't want to lose.

    This seems to be the relevant parts of the startup log in terminal:

    
    [22857:23523:0225/222623.088692:ERROR:nss_util.cc(283)] After loading Root Certs, loaded==false: NSS error code: -8018
    [23025:1:0225/222624.188436:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
    **[same message for 5 times]**
    [22995:1:0225/222626.638499:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
    [23688:1:0225/222632.513907:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [22886:22892:0225/222639.870152:ERROR:object_proxy.cc(632)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd5: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [22886:22892:0225/222639.870182:ERROR:kwallet_dbus.cc(100)] Error contacting kwalletd5 (isEnabled)
    [22886:22892:0225/222639.871060:ERROR:object_proxy.cc(632)] Failed to call method: org.kde.KLauncher.start_service_by_desktop_name: object_path= /KLauncher: org.freedesktop.DBus.Error.ServiceUnknown: The name org.kde.klauncher was not provided by any .service files
    [22886:22892:0225/222639.871090:ERROR:kwallet_dbus.cc(72)] Error contacting klauncher to start kwalletd5
    [22886:22892:0225/222639.975071:ERROR:object_proxy.cc(632)] Failed to call method: org.kde.KWallet.close: object_path= /modules/kwalletd5: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [22886:22892:0225/222639.975578:ERROR:kwallet_dbus.cc(414)] Error contacting kwalletd5 (close)
    [22857:23040:0225/222641.153428:ERROR:object_proxy.cc(632)] Failed to call method: org.kde.KWallet.isEnabled: object_path= /modules/kwalletd5: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [22857:23040:0225/222641.153567:ERROR:kwallet_dbus.cc(100)] Error contacting kwalletd5 (isEnabled)
    [22857:23040:0225/222641.154065:ERROR:object_proxy.cc(632)] Failed to call method: org.kde.KLauncher.start_service_by_desktop_name: object_path= /KLauncher: org.freedesktop.DBus.Error.ServiceUnknown: The name org.kde.klauncher was not provided by any .service files
    [22857:23040:0225/222641.154577:ERROR:kwallet_dbus.cc(72)] Error contacting klauncher to start kwalletd5
    [22857:23040:0225/222641.259979:ERROR:object_proxy.cc(632)] Failed to call method: org.kde.KWallet.close: object_path= /modules/kwalletd5: org.freedesktop.DBus.Error.NoReply: Message recipient disconnected from message bus without replying
    [22857:23040:0225/222641.260475:ERROR:kwallet_dbus.cc(414)] Error contacting kwalletd5 (close)
    [23717:1:0225/222644.632885:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [23727:1:0225/222647.097371:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [23743:1:0225/222652.782894:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer"
    
    

    This is on Kubuntu 18.04 64-bit, kernel version 4.15.0-88-generic. LDD version shows this: ldd (Ubuntu GLIBC 2.27-3ubuntu1) 2.27 (not sure if it's glibc-related though, but might help).

    Chromium works fine, Vivaldi works as well, so it seems to be an Opera-bug.

    Please advise what worth a try, and does not delete my personal data, thank you.

  • Hi @metaltrabant, try to run the Opera from a terminal window with the switch as follows: /usr/bin/opera --password-store=basic, and see if this helps.

  • @l33t4opera Thanks, tried, but it's still freezing. Resolved the kwallet issue though, but I think that was present before this problem appeared.

    The main issue will be somewhere with these errors I guess:

    "[920:1:0225/234506.590732:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
    [920:1:0225/234506.592328:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
    [1873:1:0225/234508.986148:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [891:1:0225/234515.099843:ERROR:child_process_sandbox_support_impl_linux.cc(79)] FontService unique font name matching request did not receive a response.
    [1932:1:0225/234520.356869:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [1947:1:0225/234528.269767:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [1987:1:0225/234535.877741:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [1997:1:0225/234536.569890:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer"
    
  • @metaltrabant I see. I would say it's rather not that, because I have the above errors on one of the boxes, but I don't experience this issue there.

    You can try to launch the Opera with another switch "--disable-gpu-sandbox", and if it changes nothing, then with "--disable-gpu", and check if this helps.

    Also, before trying the above, you can simply run the Opera with fresh profile (to check if the issue occurs also there), as follows: /usr/bin/opera --user-data-dir="/path/to/fresh/profile.

  • @l33t4opera It's still freezing with both of those switches.

    With a fresh profile, it starts fine, works fine, but in the terminal, throws the same errors:

    [8804:8804:0226/000852.230974:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
    [8806:8812:0226/000853.018952:ERROR:nss_util.cc(283)] After loading Root Certs, loaded==false: NSS error code: -8018
    [8976:1:0226/000853.530884:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [8996:1:0226/000853.583345:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [9021:1:0226/000853.669547:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [8804:8804:0226/000853.773064:ERROR:gles2_cmd_decoder.cc(8617)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glFramebufferTexture2D: <- error from previous GL command
    [9102:1:0226/000854.786052:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [8777:8794:0226/000858.054091:ERROR:nss_util.cc(283)] After loading Root Certs, loaded==false: NSS error code: -8018
    [9201:1:0226/000911.095481:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [9204:1:0226/000911.116550:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    [9221:1:0226/000912.649054:ERROR:child_thread_impl.cc(784)] Receiver for unknown Channel-associated interface: chrome.mojom.SearchBouncer
    

    I guess it also doesn't help that my main profile has like 64 tabs opened, and more than a dozen extensions... so the issue can be anywhere, and it's already overloaded a bit.

  • @metaltrabant Yes, it looks to be as I wrote above - those errors are not related to your issue. Perhaps you can try to test deeper with this fresh profile: open more tabs, close some, open more, install some extensions, and see if you can reproduce the issue under that conditions.

    Alternatively, if you don't want to waste much of your time on testing, you can simply use that fresh profile: install your extensions there, copy/paste your "Bookmarks", "Web Data" and so on - don't copy "Preferences" and "Local State" (of course when the Opera is closed), and try to use it daily, instead of the old one, and see if the issue will be gone for good.

    Small note: for the opened tabs, you can copy the "Current Session" and "Current Tabs" files.

  • @l33t4opera The problem is, I wanna backup a lot of stuff from that old profile, so installing clean new extensions doesn't really solve my issue... I use the developer version now, that at least synced some of my stuff (including my opened tabs), and works fine.

    Also, when I disabled extensions, one of those is The Great Suspender, and with that disabled, it didn't load my opened pages, just the pinned ones. So maybe I can narrow it down to those... but I think I'm done for tonight, thanks for your help so far 🙂 If you have more suggestions, I'll gladly try them in the morning.

  • @metaltrabant Yes, that way sounds also reasonable. You're welcome, and wish you good luck ;-)
    I will try to find some time tomorrow, and check how it's going.

  • Same problem on two linux distributions here (Arch and Neon unstable).
    Disabling synchronization solved my problem.
    Opera synchronization is still almost useless and now it also is unusable. 😞

  • @minho Okay, but how do I turn off sync in the problematic browser that hangs in about 15-20 seconds after startup? Is there a startup switch to disable sync? (I tried the obvious --disable-sync, but that doesn't seem to work)

  • open opera
    press alt+p to open preferences
    paste "synchronization" in the search field
    click on the button to disable synchronization

  • @minho It was hard to do it fast enough, but eventually I got logged out of Sync, and yes, it seems to have solved the problem. In the meantime, someone replied to my bugreport from Opera, so I'll update him with this information.

    Thank you so much for your help! 🙂 Hopefully they'll find the bug within Sync, and I can use it again, it was working fine for me so far...

  • @metaltrabant So it was the sync, which caused it in your case, nice to see it's resolved for you. It should be noticed by Opera's peeps, and investigated, and most probably improved (if not fixed) in one of upcoming versions.

  • Users affected by this problem can also disconnect from internet before open Opera, then disable synchronization in Opera settings.

Log in to reply