Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Twitch streams stutter in GX, but not normal Opera

  • @hk3wx Maybe there's some problem with using the driver for your graphics card in the browser. You can try to disable HW acceleration in Settings > system: opera:settings/system, relaunch the browser, and check if that helps.

  • @l33t4opera Issue still not fixed. In other browser it works fine tho.

  • Hi @justtheaverageuser, first of all, the issue may be a bit more complicated for Opera GX, since it's quite fresh and different product from the "normal" Opera stable. Also, the streaming may behave differently on certain hardware - I mean CPU/GPU models.
    The version of Chromium in both Operas is the same for now, so it shouldn't be cause of the problem.

    However, when it start stuttering, you can try few more things:
    1. Change to lower video quality in Twitch.tv player - for example 720p or 480p. Maybe that will help a bit in your case,
    2. Check if the "Low Latency" option is enabled under Advanced, and if not enable it, and see if it makes any difference,
    3. Enable "Video Stats" in Advanced, and see if it drops a lot of frames under "Skipped Frames".
    If so, make sure that the player is not using the flash plugin (instead of H.264 codec).
    It shouldn't use it, since it looks to be dropped a while ago. But if this is the case, you can try to disable HW acceleration in the plugin - there are many videos/tutorials on the internet on how to do that.

  • so I dont know which one fixed this for me because I forgot to test it out after enabling opera://flags/#ffmpeg-demuxer-everywhere and Shared Start Page and Override software rendering list. Then I Debloated My windows 10 and it helped tremendously for me atleast twitch doesn't lag anymore video Pop Out doesn't lag anymore etc. https://www.youtube.com/watch?v=mWHiP9K8fQ0

    I dont know which one did it but just enable all and debloat windows 10 hopefully it works on future people who gonna watch

  • disable hardware acceleration, this worked for me. had this problem since months... now, everything is fine

  • for me whenever i disable the vpn while watching videos it fixes the issue immediately going from stuttering at 480p to streaming perfect at 1080p60

  • Have the same issue, dropping 20/40 frames per second. It's isolated to opera only, no issues in other browsers.

  • @l33t4opera said in Twitch streams stutter in GX, but not normal Opera:

    Hi @justtheaverageuser, first of all, the issue may be a bit more complicated for Opera GX, since it's quite fresh and different product from the "normal" Opera stable. Also, the streaming may behave differently on certain hardware - I mean CPU/GPU models.
    The version of Chromium in both Operas is the same for now, so it shouldn't be cause of the problem.

    However, when it start stuttering, you can try few more things:
    1. Change to lower video quality in Twitch.tv player - for example 720p or 480p. Maybe that will help a bit in your case,
    2. Check if the "Low Latency" option is enabled under Advanced, and if not enable it, and see if it makes any difference,
    3. Enable "Video Stats" in Advanced, and see if it drops a lot of frames under "Skipped Frames".
    If so, make sure that the player is not using the flash plugin (instead of H.264 codec).
    It shouldn't use it, since it looks to be dropped a while ago. But if this is the case, you can try to disable HW acceleration in the plugin - there are many videos/tutorials on the internet on how to do that.

    Actually disableing the Low Latency option fixed it for me. I dont have the problem anymore.

    Ryzen 1920x
    GTX2070S

  • @zavos I'm glad to hear that ;-)

  • opera:flags
    find parameter Override software rendering list. Choose Enabled ! Done!

    "Overrides the built-in software rendering list and enables GPU-acceleration on unsupported system configurations."

    Now the video 1080p/60fps on Twitch and 1440p on Youtube runs smoothly and without interruption.
    My PC: Amd Athlon II x3 445, 6 Gb RAM, Radeon HD 7790 1Gb

  • @gregorykharlamov said in Twitch streams stutter in GX, but not normal Opera:

    opera:flags
    find parameter Override software rendering list. Choose Enabled ! Done!

    "Overrides the built-in software rendering list and enables GPU-acceleration on unsupported system configurations."

    Now the video 1080p/60fps on Twitch and 1440p on Youtube runs smoothly and without interruption.
    My PC: Amd Athlon II x3 445, 6 Gb RAM, Radeon HD 7790 1Gb

    this helped a lot, but consequently left all the images blurry, but at least I can watch twitch in 1080p60 without consuming too much cpu, and I can also disable it when not watching twitch, thanks

  • To fix the Twitch buffering issue on Opera, you should:

    1. Check your network condition: make sure it is well-connected and strong enough.
    2. Change your DNA to Google’s DNS if possible.
    3. Update your browser to the newest version, or simply uninstall and reinstall your Opera.
    4. Clear cache and cookies of your browser.
    5. Disable the extensions or addons on your Opera.
    6. Turn off Hardware Acceleration of Opera.
    7. Switch to a more powerful VPN if you are using one to surf the Internet.

    If you have done the above jobs to your Opera browser, but nothing changes, you can also try the following methods found online:

    1. Change your browser: there are many browsers you can choose from including Chrome, Firefox, IE, etc.
    2. Close the unused background applications on your computer.
    3. Upgrade your computer's hardware for HD/4K streaming.

    Resource: https://bit.ly/3xuLgNT