Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Unable to connect to Internet using Wifi network

  • Hello, I am using opera mini version 4.5 and also 8, on my Sony Ericsson P1i phone. I am using WiFi to connect to the internet from the device. But i Face a problem connecting to internet using both of the versions, however i face no problem on uc browser, inbuilt web browser, or any other application.
    I have installed the signed versions with all the certificates.
    Also my WiFi has been st to WPA security with AES cypher, if that helps.
    Any help will be appreciated. thank you!

  • Have you done a 'Network test...' ?. which is found in 'Menu / Settings / Advanced'.

  • I cannot access that because its giving me error in the first time initialization.

  • Have you done a 'Network test...' ?. which is found in 'Menu / Settings / Advanced'.

    I Cannot access that setting, because its giving me error in first time initialization. Sorry for the double posting, but how do i delete my reply? I am new around here..

  • If you can see somewhere 'allow local connection' connectivity settings then that permission must be enabled. On the other hand j2me use system default APN so the only way to set Wi-Fi access point if is not defined is to enable flight mode.

  • If Wi-Fi could be defined then APN could be enabled in suite settings via app manager but I'm not sure that will override the default 3G connection. Perhaps if default conn.(implicit proxy) is not set it may work.

  • What kind of Internet account for Opera Mini you have set in the MIDlet accounts panel in:
    Control panel>Security>MIDlet accounts>Opera Mini>MIDlet details>Internet account: ?
    It should be "System preferred".
    Have you already tried to connect to the web in Flight mode through the Opera Mobile and then parallely with the Opera Mini ?

  • Problem seems to have been solved, after i enabled the mobile network 9device was on flight mode previouly0, however i did not use any data from the mobile network, it was wifi that was connected, thank you for the support!