Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Solved]Yubikey not working (correctly) with Opera

  • Hello.
    I recently got my hands on a YubiKey 5. While using Opera I had 2 issues:

    1. I could not register the key on any website (Google, Dropbox, Gitlab, ...) they all had an error:5
    2. Using the official Yubico website to test the fido2 or u2f authentication (https://demo.yubico.com/webauthn-technical/registration) while the key is plugged in will simply crash the whole browser. After restart opera noticed it crashed but had no crashlog (automatic crashlog sending is enabled)

    Authentication with a registered device works without problem.

    I tested it again on Chrome and Firefox and everything worked flawlessly.
    I use Opera 65.0.3467.48 on Ubuntu 19.04 (x86_64; with GNOME)

  • Snap version or deb?

  • I use the deb version.

  • I have to add a small correction to the sentence: "Authentication with a registered device works without problem." ... I later noticed that logging into Github with a hardware token also crashes.

  • Sorry no idea 😞
    Launching opera from a terminal and checking its output there might help though.

  • Ok I think the problem was somewhat fixed and I don't know why.
    I read into the problem a little bit more specifically for Linux and fond that in earlier versions you had to install libu2f-host0. After installing it Opera still crashed. I came back to the problem today and it just worked somhow. I don't know why exactly especially since I restarted Opera multiple times before and after installing libu2f and I don't even know if libu2f was the problem. But somehow it just worked today. Weird.

Log in to reply