Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Slow start & zombi processes

  • Hello,

    I was getting a very slow start and these messages appeared when using the command line:

    [9977:9977:1003/140651.502921:ERROR:sandbox_linux.cc(369)] InitializeSandbox() called with multiple threads in process gpu-process.
    [9952:10046:1003/140716.798073:ERROR:object_proxy.cc(619)] Failed to call method: org.freedesktop.Notifications.GetCapabilities: object_path= /org/freedesktop/Notifications: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    [9977:9977:1003/140717.004866:ERROR:buffer_manager.cc(488)] [.DisplayCompositor]GL ERROR :GL_INVALID_OPERATION : glBufferData: <- error from previous GL command
    

    After a little hustle, I discovered that using the --password-store=basic makes Opera much faster again. I tried also with --disable-gpu --disable-software-rasterizer --password-store=basic --no-sandbox. However:

    • Sync appears to be broken (every time I open Opera, It says that it's unsynced)
    • Microphone does not work (e.g. on WhatsApp web)
    • Last but no least, when I close Opera, few processes still active, and if I want to open Opera whith these, I have to wait a lot until it opens.

    I have tried with a clean instalation a 100 times and It solver nothing. Thanks in advanced.

  • Hello, I just want to add some information, seems if you don't use gnome-keyring it will fail, especially on redhat based linux. I found this also on Chromium and Chrome browser, because I don't use Opera browser, and I guess that the chromium project have use gnome-keyring as default way to secure password account. This happend when you sync your data and some password are sync across, at first it will use gnome keyring to secure the data, and if it's not available, it will keep trying and eventually after you close the brower and reopen it, it will force to do data encryption until it succed where as it won't succeed, especially if you don't use gnome desktop, I just moved from gnome to xfce and it suck, anyway thanks for --password-store=basic flag, now mine also working, so in the end I think we should open bug report on the chromium project about this.

  • @benyamin90 I have reported this issue as a bug to the Opera wizard. I use Manjaro stable and a desktop (KDE Plasma) that is not based on gnome, perhaps that is what causes the keyring to fail. I think Opera shouldn't rely on the desktop being used.

    Also regarding the des-sync, it happens only sometimes to me, and i couldn't figure it out when exactly it happens.

Log in to reply