Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

A fatal bug: error DNS_PROBE_FINISHED_NO_INTERNET on everything

  • Hello. I recently downloaded Opera GX for my PC. I love the browser and would love to keep using it, but there's a bug that keeps completely disabling internet for my computer, making it nearly useless. I'll use it with no issue for an amount of time, generally from half an hour to an hour. Then, out of the blue, I get the error DNS_PROBE_FINISHED_NO_INTERNET on everything. Every browser has this error, no games will load, basically nothing works. Although, if the error occurs while I'm playing a game, it won't disconnect me, and I can play until I leave the lobby. I'm still totally connected to the internet, but not really. It only happens while I'm using Opera GX, although this may be a coincidence. Although, using chrome earlier, I had no problem. I've already reinstalled it twice. If anyone knows how to fix this, please tell me. So far, the only working solution is to restart the computer, but it just happens again.

  • Do you using wifi connection? If you using wireless keyboard or mouse try to plug them off. If it fix your internet connectinon it means that your wireless reciever for kb/mouse working on the same frequency as youre Wi-fi router. Also you can change DNS server to 8.8.8.8 (google), maybe it's problem with your provider. Also check DNS Client Service it should have status Running.

  • @abrgpro No, I don't use any wireless peripherals, nor am I connected to WiFi. I'm using Ethernet. I've already tried changing the DNS several times, but it makes no difference.

  • @abrgpro Also the DNS Client Service is running even when I get the error. Also, using any other browser causes no issue, just as an update.

  • Since Opera is based on Chromium you could try the following:

    1. Clear DNS Cache of Opera
      a) Go to ‘chrome://net-internals/#dns‘
      b) Click on Clear-Host Cache button next to Host resolver cache.

    2. Turn ‘Use Prediction Services to Load the Pages more Quickly’ off in the 'Privacy and security' settings page and then restart the browser.

    3. Try flushing the DNS cache.
      a) Exit the browser
      b) Open the Command Prompt
      c) Type 'ipconfig /flushdns' and then Enter
      d) Type Exit to close the Command Prompt
      e) Start the browser

  • @PeterBurton tried it, no luck. It seemed to work for longer though

  • @wenoay Sorry my suggestions did not help. If you are using VPN please turn it off -- it cannot hurt.

    I did find a website which listed my suggestions as well as others ( with pictures 🙂 ) so perhaps they might work: https://www.digitbin.com/fix-dns-probe-finished-no-internet

Log in to reply