Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Lost profile/settings after running Opera as sudo.

  • Hello Dear Community

    Background story:
    From time to time I had a problem with my Opera on my xubuntu 19.04 where from time to time(once week maybe), after turning on PC and starting the Opera, the Opera window appeared for like maybe 1 second and then crashed. Opera then starts to reboot itself few times, every times the same story happens with the message above bookmarks that Opera has crashed, and then after few times it gives up.
    After dozens tries of running again it somehow finally runs.
    But anyway, that lead me to check what will happened if I run Opera as sudo and it worked with all my settings(but I was not logged on common mails, forums etc. however).
    After that running normally the Opera works and gives message box that: user profile could not be found, etc

    I am not much concerned with the background story issue, because I beleve it would be to complicated to find the reason etc. so I just wonder if could there be anything I could try to do in such a case. I guess knowing where the user profile should normally be and what actually this running Opera as a sudo did.

    Thanks

  • How did you manage to run opera with sudo? Opera, like any chromium based browser, can not be run with root rights

    $ sudo opera 
    [sudo] password for jim: 
    [2496:2496:0627/151950.675965:ERROR:zygote_host_impl_linux.cc(89)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
    
  • It seems yes, I've just added "--no-sandbox"

  • Speechless...
    Does/did opera launch the way it used to when you run it with sudo or does/did it run as if it was fresh install? I assume it run as a fresh install, because it was run as root,
    In fact, forget running it with sudo if you do want to solve your issue.

    Without opera running, make sure that the folder /home/yourusername/.config/opera still exists and back it up somewhere, then delete it (or rename it). Launch opera as usual, without sudo. If it does launch, close it and copy the backed up folder to its original location.
    Did that solve your problem?

  • @jimunderscorep
    When run by sudo it did run with all my settings, bookmarks, whatapp, etc.
    I did a mistake and did not do the copy and restarted the system, and then I've lost bookmarks, whatsapp, etc, but the basic settings seems to be ok.
    I think now it's too late and I will just give up.
    One of my guess what happened is that some files got permission changes and later normal opera startup could not load some of the files.
    Anyway, thanks for concern.

  • @davis89x said in Lost profile/settings after running Opera as sudo.:

    One of my guess what happened is that some files got permission changes and later normal opera startup could not load some of the files.

    I thought of that too.
    Since opera can run with sudo and lauched like it used to, use it one last time to save your bookmarks at least, by exporting them.
    Then delete the entire folder I mention above and, once it launches again, you will have a fresh install of opera to import your bookmarks and adjust it like you want.

  • @jimunderscorep
    No, the bookmarks were lost as I said because I did restart of the system.
    I've just tried to chown the whole folder and files of config/opera and now it works like with sudo, meaning bookmarks, sites logins, whatsapp, etc. are lost, but basic settings, history, etc. are now back again in normal mode.
    I am just not sure if by default all of files of this folder are owned by normal user or some of them are roots one so that there is not any privacy leaks or sth.

Log in to reply