Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

How to disable javascript - or how to force legacy twitter on opera mini?

  • It all was fine until a few months back.
    I was using probably v38.x, cookies disabled, extreme data saving.
    And I could load legacy twitter.

    Then v39.x came out I installed it and a few days later or so I couldn't get legacy twitter to load. I even went back to v38 - which is a p.i.t.a. on android as downgrade isn't really possible, at least not without loss of data/settings - even with backup and rooting etc.
    But to no avail.

    Since then I can't read twitter anymore as twitter will not set any cookies on my watch and twitter won't let me see anything without cookies - as I can't get opera mini (now v42) to load twitter legacy. Which even works on desktop (any browser) - just disable cookies (and maybe javascript), but that does not work on opera mini anymore.

    I read somewhere in another context that opera changed the behind the sceenes settings for the server that feeds the data saving modes. So maybe Opera enabled javascript for twitter in data savings modes i.e. on that feeding server. I don't know. I only know that I don't like what happened a few months back (maybe march or february 2019?).

    Is there any way to disable javascript on opera mini (or maybe opera for android) or way to it rather easily via firewall or other blocking?

    And as we're at it: When will opera mini or opera for android finally be able to enable and disable features on a domain basis and not just generally for all sites? There are sides that I will never ever allow to set any cookies - that's why I have to use both opera browsers available for android, one that has cookies enabled and one that hasn't.
    Also, why can't I set a custom search engine? The default ones are not to my liking, especially in opera mini. And having to go via the startpage which is just a fancy way of bookmarks, is a little old-fashioned for my taste.

    Cheers,
    Mike

  • @op-us Twitter works for me in Opera Mini 42 in exteme mode on a Samsung S7. Probably an issue specific to your device. You should file a bug report.

    To add a search engine, open the search engine you want to add, do a long press in the search box and choose "Add search engine" from the pop-up menu. Only works with search engines that use a web form with the get attribute. You can add DuckDuckGo but not Startpage as it uses post rather than get.

  • @ legacy twitter: Please re-read my post. I didn't say twitter wasn't working with extreme mode. I said legacy twitter not working anymore with extreme mode since a few months back.

    But: Since June 4th I have it working again. I did some testing and finally added ma.twimg.com on the black list in adaway. It didn't make any difference. I didn't reboot the device and didn't restart consciously opera. But 1-2 days later finally twitter loaded in legacy/classic design mode again instead of the "normal"/desktop design which requires cookies to be enabled to show content.
    So, if Opera didn't do any changes to their "proxy"-server settings I guess blocking that url/domain that hosts twitter's js files using adaway seems to work even though initially it didn't look like.

    @ search engines: Thanks for the hint! Of course my favourite one uses post, too... 🙂 But at least I now can add some more.

Log in to reply