Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera crashing/freezing on start. GPUCache issue.

  • Hi!

    Stability recently really took a hit with the latest Opera releases...

    Currently I am having this beautiful "user experience":

    Whenever I close Opera or restart my Linux box, I can not open Opera again.

    It immediately freezes Gnome, everything becomes unresponsive.

    Only thing I can still do is switching to a console and reboot from there.

    After manually deleting .config/opera/GPUCache and .config/opera/ShaderCache/GPUcache it usually starts again.

    It does not matter if I have GPU hardware acceleration active in settings or not.

    Any ideas how to solve it? Really annoying.

    Running latest release on Solus with Gnome desktop.
    System is a Ryzen 2400G with integrated Vega graphics, which is quite stable and fast with the latest kernels.

  • Hi @MartinTheWanderer, as a workaround to the issue you can try to run the Opera with the switch as follows: /usr/bin/opera --disable-gpu-shader-disk-cache, and check if this helps.

  • @l33t4opera sounds reasonable, will give that a try and report back.

    BTW starting Opera with a fresh profile works, but for obvious reasons I don't like to start over every time some update messes something up LOL

  • Ha!

    thanks @l33t4opera , that seems to solve it. Still a bit strange why Opera does not clean up after itself properly and instead crashes when using the cache...

    BTW when started from a terminal, Opera always shows this message, before it freezes (but also when it decides to work):
    [1837:1837:0110/093750.391591:ERROR:sandbox_linux.cc(379)] InitializeSandbox() called with multiple threads in process gpu-process.

    Related?

  • Hi @MartinTheWanderer, you're welcome. It looks like a bug in some cases, I can't reproduce it myself. You can file a report about it, using Opera's bug report wizard. Regarding second issue, try to run the Opera with --disable-namespace-sandbox switch, but even it fixes it, that's also a workaround to the real problem, perhaps it will be fixed in one of next versions of Chromium.

Log in to reply