Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Fully blocked notifications only with Opera.

  • Hello, I can't find solutions in internet for the issue that took me here. The notification tag shows up, blocks my Opera, and after a minute or two with it blocked, the tag stays there, over everything, fully blocked, and the other stuff starts working again.

    If any notification shows up again, it happens the same. A couple minutes waiting until the program start to work again and the same previous tag stays there... I noticed that Guake and Slack notifications works fine, and they are different to the Opera ones. These first ones have an X to close them, and the Opera ones have an 'Activate' button, but not cross to close at all. Smells like Opera issue to me.

    I have a not-that-bad desktop gaming PC, with nvidia GTX 1050Ti 4GB (with non-free drivers), an i5 processor, an MSI Z270 MB and a GSkill Trident Z 8 GB ram. I'm using the last Debian 9.0.5 release for this date, installed a couple days ago. I'm using Gnome MATE, and the last Opera version, installed today or yesterday. (56.0.3051.99) 'Recovery and Update' option didn't worked. I didn't find any solution searching in this forum.

    ┬┐Where can I start to solve the issue?

    Thanks for any help.

  • Guake and slack probably use the system;s notification daemon to show their notifications while opera uses its built ine one to show web notifications.

    You can disable them through settings > advanced > provacy + security > content settings > notifications and flip that switch to off. The text next to it won't change as it does in chromium (a bug probably), but web notifications will be disabled. You can check if it worked in a test page like this one

  • Hello. Finally it seems to happen to Slack and Rythmbox too. So I don't really know if is only an Opera issue or a system one. I'll try to reinstall MATE or the notifications library or whatever is involved in this thing.

  • This post is deleted!