Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Debian 9, Opera not starting

  • Hello,

    I've been having problems with Opera running on my Debian 9 computers. She has been my browser of choice for a long time now, this is the first time i have issues with it, i hope it's ok to post that here.

    I have multiple PC both at home and at work, all of them have the same version of Debian and the same version of Opera so naturally all of them have the same problems. It's pretty simple, It won't start, well it does start eventually after i click a few times and then it opens multiple windows of Opera along with the error message that states the profile folder is not accessible. All of my PCs are on the latest versions from the official repositories along with the backports

    This only happens the first time i run it after a reboot, it works fine once it has started, I was hoping somebody will report this and that it will be fixed in the future updates but it's been 2 updates since then and the problem still persists.

    I don't really get any errors when running from the console.
    I've tried deleting the .cache/opera and .config/opera folders and it starts fine the first time with all the settings reset and then on the next startup i get the same problem.
    I've tried deleting all of my sync data to exclude the possibility that there's something wrong with my bookmarks or passwords, i had a bunch of stuff there, didn't help.
    I've even tried purging everything and installing again.

    Is any one experiencing the same problems and if you do, is there a solution?

    Thank you very much!

  • Hello again,

    I've took to time to properly test this issue.
    When i try to start it from the console i get this:

    tomislav@w230st:~$ opera
    Fontconfig warning: "/etc/fonts/fonts.conf", line 160: blank doesn't take any effect anymore. please remove it from your fonts.conf
    ATTENTION: default value of option force_s3tc_enable overridden by environment.

    And it just gets stuck like this,not starting. If i manage to start it after a few tries i get this:

    tomislav@w230st:~$ opera
    Fontconfig warning: "/etc/fonts/fonts.conf", line 160: blank doesn't take any effect anymore. please remove it from your fonts.conf
    [10671:10680:0524/081439.085479:ERROR:browser_gpu_channel_host_factory.cc(119)] Failed to launch GPU process.

    I've got hybrid graphics with Intel 4600 and Nvidia GTX 765m, I've tried to fix the GPU process error by setting the $BROWSER variable to opera, It didn't solve the error but now i get this:

    tomislav@w230st:~$ opera
    Fontconfig warning: "/etc/fonts/fonts.conf", line 160: blank doesn't take any effect anymore. please remove it from your fonts.conf
    [17344:17382:0524/081717.891992:ERROR:connection.cc(1907)] History sqlite error 5, errno 0: database is locked, sql: DELETE FROM meta WHERE key=?
    [17344:17378:0524/081717.895505:ERROR:in_progress_cache_impl.cc(93)] Could not read download entries from file because there was a read failure.
    [17344:17382:0524/081717.895636:ERROR:connection.cc(1907)] History sqlite error 5, errno 0: database is locked, sql: UPDATE downloads SET state=?, interrupt_reason=? WHERE state=?
    Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
    Gkr-Message: secret service operation failed: The name org.freedesktop.secrets was not provided by any .service files
    ATTENTION: default value of option force_s3tc_enable overridden by environment.
    [17344:17381:0524/081718.196123:ERROR:connection.cc(1907)] Web sqlite error 5, errno 0: database is locked, sql: COMMIT
    [17344:17381:0524/081718.196224:ERROR:connection.cc(1907)] Web sqlite error 1, errno 0: cannot start a transaction within a transaction, sql: BEGIN TRANSACTION
    [17344:17381:0524/081718.197609:ERROR:connection.cc(1907)] Web sqlite error 1, errno 0: cannot start a transaction within a transaction, sql: BEGIN TRANSACTION
    [17344:17360:0524/081718.917502:ERROR:gcm_store_impl.cc(309)] Failed to open database /home/tomislav/.config/opera/GCM Store: IO error: /home/tomislav/.config/opera/GCM Store/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
    [17344:17360:0524/081719.918757:ERROR:gcm_store_impl.cc(419)] Destroy failed: IO error: /home/tomislav/.config/opera/GCM Store/LOCK: No further details. (ChromeMethodBFE: 15::LockFile::1)
    [17344:17353:0524/081719.918825:ERROR:gcm_client_impl.cc(849)] Failed to reset GCM store
    [17344:17353:0524/081720.095983:ERROR:ticl-message-validator.cc(212)] registration_digest must be non-empty
    [17344:17353:0524/081720.096017:ERROR:ticl-message-validator.cc(319)] field registration_summary failed validation in { protocol_version: { version: { major_version: 3 minor_version: 2 } } client_token: "WxSrozuOzbh0fKUgpczArQ==" registration_summary: { num_registrations: 0 registration_digest: "" } server_time_ms: 0 }
    [17344:17353:0524/081720.096040:ERROR:ticl-message-validator.cc(361)] field header failed validation in { header: { protocol_version: { version: { major_version: 3 minor_version: 2 } } client_token: "WxSrozuOzbh0fKUgpczArQ==" registration_summary: { num_registrations: 0 registration_digest: "" } server_time_ms: 0 } }
    [17344:17353:0524/081720.096068:ERROR:protocol-handler.cc(145)] Received invalid message: { header: { protocol_version: { version: { major_version: 3 minor_version: 2 } } client_token: "WxSrozuOzbh0fKUgpczArQ==" registration_summary: { num_registrations: 0 registration_digest: "" } server_time_ms: 0 } }
    [17344:17382:0524/081721.382221:ERROR:connection.cc(1907)] History sqlite error 5, errno 0: database is locked, sql: INSERT OR REPLACE INTO meta (key,value) VALUES (?,?)
    [17344:17344:0524/081721.382435:ERROR:sync_metadata_store_change_list.cc(34)] Typed URLs datatype error was encountered: Failed to update ModelTypeState.

    I get the same error when i try to run it with Nvidia. Despite the errors in the console, Opera works normally after being started
    I hope this helps

  • Despite the fact that hybrid graphics are a sad story for linux in general, I would suggest disabling opera's 3d acceleration and trying.