Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • When autofill provides a drop down list for a text box, if you mouse over one of the options it fills in the corresponding text in the text box. This is super annoying as it should only replace the text in the text box if you actually select the corresponding autofill entry, like autofill on every other modern web browser. The problem is if the mouse cursor happens to be just below the textbox while you are typing with the keyboard, it will overwrite the textbox with simply the mouse hovering over the autofill entry. Or, you may jiggle the mouse or inadvertently touch the touchpad while typing and overwrite what you are typing. This really serves no purpose anyways, as the value that is displayed in the textbox when this happens is for display only. It doesn't actually replace the actual value until you click on the autofill entry. The better, and standard solution, is to simply do nothing on hover, and only change the textbox value when you click on the corresponding autofill value.

  • +1.
    This is extremely annoying. Example - I only use mouse to select the first input field, then I jump using Tab only. But because the autofill form suddenly appears under the mouse, pressing Tab causes the highlighted value to be put into the form instead of "1":
    Sample of bug

    Is there a way to at least disable the auto-fill feature at all?