Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera doesn't recognize system proxy on fedora 26

  • Hi all🙂 ,
    the terminal shows:
    "$ opera

    (opera:7684): libnotify-WARNING **: Failed to connect to proxy
    [7684:7716:0405/140346.676248:ERROR:in_progress_cache_impl.cc(93)] Could not read download entries from file because there was a read failure.
    [7684:7684:0405/140347.304919:ERROR:input_translator_internal.cc(272)] Wrong definition of keybinding.
    [1:17:0405/140348.245188:ERROR:adm_helpers.cc(73)] Failed to query stereo recording.
    [7684:7710:0405/140350.764966:ERROR:ticl-message-validator.cc(212)] registration_digest must be non-empty
    [7684:7710:0405/140350.764985:ERROR:ticl-message-validator.cc(319)] field registration_summary failed validation in { protocol_version: { version: { major_version: 3 minor_version: 2 } } client_token: "a0O1/3LJ2sLen23pQdigzQ==" registration_summary: { num_registrations: 0 registration_digest: "" } server_time_ms: 0 }
    [7684:7710:0405/140350.765007:ERROR:ticl-message-validator.cc(361)] field header failed validation in { header: { protocol_version: { version: { major_version: 3 minor_version: 2 } } client_token: "a0O1/3LJ2sLen23pQdigzQ==" registration_summary: { num_registrations: 0 registration_digest: "" } server_time_ms: 0 } }
    [7684:7710:0405/140350.765029:ERROR:protocol-handler.cc(145)] Received invalid message: { header: { protocol_version: { version: { major_version: 3 minor_version: 2 } } client_token: "a0O1/3LJ2sLen23pQdigzQ==" registration_summary: { num_registrations: 0 registration_digest: "" } server_time_ms: 0 } }
    [7684:7684:0405/145611.033401:ERROR:settings_utils_linux.cc(53)] Could not find XFCE network settings in $PATH
    [7684:7684:0405/145611.081012:ERROR:CONSOLE(217)] "Unexpected condition on chrome://linux-proxy-config/: Could not find value for themesEnabled", source: chrome://resources/js/load_time_data.js (217)
    [7684:7684:0405/145611.081052:ERROR:CONSOLE(217)] "Unexpected condition on chrome://linux-proxy-config/: [undefined] (themesEnabled) is not a boolean", source: chrome://resources/js/load_time_data.js (217)"
    How can I fix this ? Thanks for your help.
    Regards.
    pll

  • Start opera like so
    opera --proxy-server=your-proxy-ip:port
    e.g
    opera --proxy-server="192.168.1.5:8080"
    and report back.

  • Hello jimunderscorep,
    I just try with privoxy, the terminal returns:
    "$ opera --proxy-server="127.0.0.1:8118"

    (opera:7424): libnotify-WARNING **: Failed to connect to proxy
    [7424:7439:0405/211103.242562:ERROR:in_progress_cache_impl.cc(93)] Could not read download entries from file because there was a read failure.
    [7424:7424:0405/211103.455761:ERROR:input_translator_internal.cc(272)] Wrong definition of keybinding.
    [1:16:0405/211104.348899:ERROR:adm_helpers.cc(73)] Failed to query stereo recording."
    Also, I check privoxy here: "https://www.privoxy.org/config/" the message is: "Privoxy is not being used".
    Opera failed to connect to proxy. How to fix this issue ? Thanks.
    See you soon.
    pll

  • This issue comes on xfce environment. Opera can connect to the proxy on kde environment. I think this is an incompatibility between Opera and xfce. How to solve it ?

  • Sorry then, no idea. I do not use fedora or xfce or kde. Can't you set your proxy settings somewhere systemwide? How did you set it under kde?

  • I try proxychain. It works with Firefox but not with opera☹ . Under kde the setting is reachable but changes nothing☠ .
    Opera needs too much time to start (more than 30 seconds). Reduce this time should be a good thing ! Is there a command line to ignore "libnotify" ?

  • Now Opera starts very quickly:
    "$ opera
    [5799:5825:0408/143743.949652:ERROR:browser_gpu_channel_host_factory.cc(120)] Failed to launch GPU process."
    For another reason I reseted NetworkManager:
    "# rm -rf /etc/NetworkManager/system-connections"
    "# systemctl stop NetworkManager"
    "# rm /var/lib/NetworkManager/NetworkManager.state"
    "# systemctl start NetworkManager"
    "# reboot"
    Maybe the first or all the commands lines solve the issue.
    I have to check if Opera accept proxies.
    I 'll come back.
    Friendly.
    pll

  • After one or two restarts, the "libnotify" error came back, and Opera became slow to start again.
    To fix it, I started the daemon "xfce4-notifyd" with:
    " systemctl --user start xfce4-notifyd.service"
    and I put it on the start up. What 's good !
    But Opera doesn't recognize proxies anyway ☹ .
    See you...
    pll

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.