Opera 49.0.2725.34 not launching on Kali after install

  • I've had no problems with Opera in the past. I made an update to 49.0.2725.34 and it stopped launching.

    cat /etc/lsb-release

    DISTRIB_ID=Kali
    DISTRIB_RELEASE=kali-rolling
    DISTRIB_CODENAME=kali-rolling
    DISTRIB_DESCRIPTION="Kali GNU/Linux Rolling"

    I was able to install and launch a much older version of Opera 12 with no problems.
    Output from my most recent install of Opera 49:

    dpkg -i opera*

    Selecting previously unselected package opera-stable.
    dpkg: considering removing opera in favour of opera-stable ...
    dpkg: yes, will remove opera in favour of opera-stable
    (Reading database ... 434945 files and directories currently installed.)
    Preparing to unpack opera-stable_49.0.2725.34_amd64.deb ...
    update-alternatives: using /usr/bin/firefox-esr to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
    update-alternatives: using /usr/bin/firefox-esr to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
    Unpacking opera-stable (49.0.2725.34) ...
    Setting up opera-stable (49.0.2725.34) ...
    update-alternatives: using /usr/bin/opera to provide /usr/bin/x-www-browser (x-www-browser) in auto mode
    update-alternatives: warning: skip creation of /usr/share/man/man1/x-www-browser.1.gz because associated file /usr/share/man/man1/opera.1.gz (of link group x-www-browser) doesn't exist
    update-alternatives: using /usr/bin/opera to provide /usr/bin/gnome-www-browser (gnome-www-browser) in auto mode
    update-alternatives: warning: skip creation of /usr/share/man/man1/gnome-www-browser.1.gz because associated file /usr/share/man/man1/opera.1.gz (of link group gnome-www-browser) doesn't exist
    Processing triggers for menu (2.1.47+b1) ...
    Processing triggers for hicolor-icon-theme (0.17-1) ...
    Processing triggers for gnome-menus (3.13.3-9) ...
    Processing triggers for desktop-file-utils (0.23-2) ...
    Processing triggers for mime-support (3.60) ...
    Processing triggers for shared-mime-info (1.9-2) ...
    Processing triggers for man-db (2.7.6.1-2) ...

    Appreciate your suggestions.

  • If you use kali as stock, that means with only the root user available, it's because opera can not be run as root
    # opera [1113/071120.729838:ERROR:zygote_host_impl_linux.cc(88)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.