Chrome web store extensions are not working in Opera

  • Hello Opera Team

    To two previous versions of Opera I use the extension "Download Chrome Extension". With it I can download extensions from the chrome web store, however, it is giving error and the browser closes and does not install any extension of the store "chrome web store". I have completely removed the browser and deleted all the folders and even then the following error message appears, as below.

    Download Chrome Extension
    Unable to download the package from the network error.
    Check you internet connection and try again.

    Obs. Information for the FIM that my connection is normal.

    Linux version I am using:

    Version: 48.0.2685.35 - Opera is updated
    Refresh stream: Stable
    System: Ubuntu 16.04.3 LTS (x86_64; Unity)

    If you can help me in this matter I am grateful!

    Edson Santos

  • It is a bug and it was reported some days ago here, along with a workaround

    http://forums.opera.com/topic/22600/i-have-download-chrome-extension-add-on-but-i-still-can-t-download-chrome-extensions

    It's maintainer however does has not replied yet at the issue I opened at its github page :(

  • Hello l33t4opera

    I've tried the above tips, the extension is installed, but it does not work.
    Besides this problem, the last two versions of Opera here for me are very unstable. I think we will have to wait for some solution from the developers.

    Thank you in advance for your attention.

    Edson

  • I'm having a similar issue. I was able to download the Chrome extension Cybrhome New Tab Page. However, only the options page installed instead of the full extension. Not sure how to resolve this.

  • Hello operauser

    Yes, in Windows it is working normally. The problem so far is specific to Linux, where other people have also complained about the same situation, as can be seen here. (https://github.com/operasoftware/chrome-webstore-extension/issues) Apparently it seems to be the extension "Download Chrome Extension" after version 2.3.0 and 2.4.0. I ran several tests and apparently it's the extension.

    As an indication, I circumvented this with the CRX "Extension source viewer" and I was able to install the Chrome Web Store extensions normally.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.