Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 12.17

  • legacy Opera = version 12 and below

  • thanks for the answers 🙂 .

    Do you know if there will be any update to the. newer versions?

  • It's ALIVE I tell you IT'S ALIVEEEEEEEE!!!

  • They're security fixes and another indication that the Opera Team care about its user base.

  • I just tested 12.17.
    It's same defective release as 12.16. Cookies support has broken, rendering bugs... 12.14 is a version of my choice.

    They're security fixes and another indication that the Opera Team care about its user base.

    Too bad they don't care about quality control anymore :(. At least for Opera Presto browser.

  • @stng
    Oh please...

    Too bad they don't care about quality control anymore :(. At least for Opera Presto browser.

    You know about Opera's devs internal workflows? Opera 12.x gets security bugfixes.
    The rest will not be fixed because it's no priority. Opera ASA develops Opüera 20 (Blink) now, you know?

    Lets see what the upcoming chaneglog will say about fixes.

  • I just tested 12.17.
    It's same defective release as 12.16. Cookies support has broken, rendering bugs... 12.14 is a version of my choice.

    And outlook.com is not working in the x64 version just as in the 12.16 version....

  • Does anybody know the file that i have to replace to get outlook working in x64 ?
    I cant remember and the old forum is unfortunatly gone....

  • @angiesdom

    You know about Opera's devs internal workflows? Opera 12.x gets security bugfixes.

    Excellent!

    The rest will not be fixed because it's no priority. Opera ASA develops Opüera 20 (Blink) now, you know?

    Too bad they accidentally making new bugs with these minor fixes. Making some sites completely unusable (a web-pages which works fairly well in 12.14).

    @findkfn

    Does anybody know the file that i have to replace to get outlook working in x64 ? I cant remember and the old forum is unfortunatly gone....

    Try 12.14 x64

  • @findkfn

    Does anybody know the file that i have to replace to get outlook working in x64 ? I cant remember and the old forum is unfortunatly gone....

    Try 12.14 x64

    Yes, that works, but it was only a missing/defective file in the 12.16 x64 installation file that prevented outlook (and maybe other sites) from working.
    It was possible to replace this file with the one from the x86 version.

  • Yes, use insecure old software like Opera 12.14.

  • Yes, use insecure old software like Opera 12.14.

    For the amount of sites that work in 12.14 and fail in 12.16 (and I guess 12.17 too), for me, it's worth it. Especially when the functionality between the two is pretty much the same.

  • Nevermind, just found it: public_domains.dat
    Its missing in the x64 installation, you can replace it with the one from the x68 installation.

    Yes, use insecure old software like Opera 12.14.

    Yes, i will if i want.

  • Nevermind, just found it: public_domains.dat
    Its missing in the x64 installation, you can replace it with the one from the x68 installation.

    Yes, use insecure old software like Opera 12.14.

    Yes, i will if i want.

    Thought you were using 12.16 ?, from what you said up there ^.

  • I believe they will end the support soon, the same thing that happened with Windows XP.

  • I believe they will end the support soon, the same thing that happened with Windows XP.

    But that does not make it function any less, and it will still work (for me) the day after they drop support as well as it did the day before. #Shrugs#

  • Thought you were using 12.16 ?, from what you said up there ^.

    I was using 12.14 because of some site incompatibilities but now im trying 12.17.
    I just remembered the outlook problem in 12.16 x64 (and apparently now also in 12.17 x64)

  • You people are really naive ...

    With version 12.15 they "accidentally" introduced bug(s) which made Opera Presto have even more site compatibility problems, then with version 12.16 they, again todally "accidentally", deleted a file from x64 version what brought even more site compatibility problems. And now we have v12.17 which doesn't fix any of those issues. Coincidence? Really, really?

  • OMG how could I forget that certificate theft and that they didn't even mention v12.16 on their blog. Huh, of course they care.

  • Coincidence? Really, really?

    Paranoia? Really, really? Uh... these are professional developers. They're not going to purposely scuttle Opera Presto. Opera Presto is already dead and it's only a matter of time before it becomes entirely useless. What they ARE doing is providing security fixes. If you don't like them or (perish the thought) don't trust them... DON'T UPDATE. It's really as simple as that.

Log in to reply