Search engines keep disappearing

  • Hi everyone,

    this is probably the first bug I encountered that keeps me completely in dark.. Forced me to create an account on the forums since it bugs me quite a lot. 😄

    In last approx. 5 months of using Opera on Linux, now a total of three times all my search engines vanished. The default search engines as well as search engines added by extensions are still present and working and I can add all the vanished engines again but it is pain to do so even once since I have more than 10 that I actively use, some with custom URL.

    Unfortunately I cannot find any clue why or how this happens but since yesterday (last occurrence) I suspect it is tied to "random" crashes of the browser itself that happen sometimes (on average about once per 2 weeks, no idea why as well). The browser either suddenly completely closes itself or "almost freezes", usually freezing whole computer soon after. These crashes usually happen after some long time of inactivity, that's about the only connection I noticed. Once, my profile folder got corrupted (I got a notification message) but normally it just crashes and when I start it again, everything looks fine. No message saying the browser crashed or offering to send a crashlog somewhere.

    This brings me to my question(s), is there any crashlog I could search for clues or upload for others? Or does anyone have/had similar experience and knows what to do about it? And ultimately, has anyone thought about saving the search engines configuration into Opera account and cloud to share across more computers and/or making restoring them easy?

    I am using Opera from official stable repository (https://deb.opera.com/opera-stable/) on Linux Mint 18 Cinnamon. My current version is 45.0.2552.881 and I will update it after this but the same bug definitely occurred on more than one version.

    Thanks in advance for any tips.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.