Opera developer can't start on some Linux distros since build 46.2602

  • Opera developer build 46.2602 now requires GKT-3, while any of the previous builds (I was using 46.2556) was perfectly happy to work with just GTK-2 libraries. This new, higher requirement cuts off from using Opera all Linux distros that don't include native GTK-3. Those are mostly the minimalistic distros -- minimalistic not in the sense of "very few users" but rather of "low system resources needed".

    Is there a possibility to go back to requiring just GTK-2 in a future build?

    objdump -p opera-developer 46.2556 vs 46.2602 diff
    2556   NEEDED               libgtk-x11-2.0.so.0
    2556   NEEDED               libgdk-x11-2.0.so.0
    2602   NEEDED               libcairo.so.2
    2602   NEEDED               libgtk-3.so.0
    2602   NEEDED               libgdk-3.so.0

    Opera couldn't start even when I installed GTK-3 and GTK-2 libraries side-by-side. Running from a shell prompt:

    # opera-developer
    (opera-developer:21217): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
    Trace/breakpoint trap

    The bottom-line: the last developer build before 46.2602 is the end of the line for low-in-system-demand Linux distros that are based on GTK-2, such as Puppy Linux, that is unless Opera devs remove the on GTK-3 that they introduced in build 46.2602.

    Above information submitted as DNAWIZ-16093.

  • I believe the correct tracker reference is DNAWIZ-61093.

Log in to reply

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.