Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera does not remember window size

  • Steps to reproduce:

    • On Arch Linux+Gnome install Opera from AUR repositories
    • After installation is done, start Opera
    • Maximize window
    • Close Opera
    • Open Opera

    Expected behavior:
    Opera will start in maximized window as it was closed

    Current behavior:
    Opera will start in smaller window and must be maximized again

  • Same here (debian testing x64, openbox and opera installed from their repo). There is already an open topic about it, so please post there 🙂

  • I found this list

    and it shows "-start-maximized" as a parameter.

    Put it in the Opera launcher and bingo.
    Opera now opens maximized with this command in the launcher:

    in Linux:

    opera %U --start-maximized

  • Thanks a lot for the tip!

  • Here's where this stands now:

    Opera now doesn't open properly in Linux Mint anymore, it doesn't open maximized by itself.

    If you open the launchers and change the command from "opera %U" to "opera %U --start-maximized", then it opens mid-size at first, then jumps to maximize. This is great!

    However, this only works in each specific launcher, and the "new window" and "new private window" options from the icon on the taskbar/panel, well, their launchers are "missing" - can't find them anywhere.

    Below is the file "opera.desktop" from "/usr/share/applications" in Linux Mint 18.1 Cinnamon.

    it's the only file I can find that refers to "new window" and "private window" - I couldn't find anything about opera in "~/.local/share/applications/" but there's other copies of this in


    But when I edit the 2 lines that say

    "Exec=opera --new-window" to say "Exec=opera --new-window, --start-maximized"
    "Exec=opera --private" to say "Exec=opera --private, --start-maximized"

    there's no change in the window behaviour. What am I doing wrong here?

    This is the file, I edited it as root even:

    [code][Desktop Entry]
    GenericName=Web browser
    Comment=Fast and secure web browser
    Exec=opera %U --start -maximized

    [Desktop Action NewWindow]
    Name=New Window
    Exec=opera --new-window

    [Desktop Action NewPrivateWindow]
    Name=New Private Window
    Exec=opera --private

    I'm really getting lost here - do we have someone who can see what I'm doing wrong? Does anybody know the right syntax for this? Specifically the "EXEC" lines.

  • How do I edit this so you can read the file contents? It's messed up.

  • You just change the 7th line in the file from

    Exec=opera %U


    Exec=opera %U --start-maximized

    And here are the contents of the whole opera.desktop file if you want to check

    (the link is valid for 7 days)

  • new to both opera and also linux mint.
    I see your advice but not sure how to impliment.
    Can you do a step by step for a learner please

  • Open the opera.desktop file like so

    sudo gedit /usr/share/applications/opera.desktop

    Find the line I mention above (the 7th one) and change it to what I say. Then save and exit.

  • Put command in with this reply:sudo: gedit/usr/share/applications/opera.desktop: command not found

  • There is a SPACE between "gedit" and "/usr/share/blablabla"...
    Please type it correctly 😛