Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera can't open external links

  • Hi everyone,

    Description :

    I'm using Discord, Slack etc, and when I want to open a link, a tab opens and shows me the home page ... It also happens with Gyazo when I want to take a screenshot.

    Here are the details on Opera version and the distrib I'm using :

    Version : 44.0.2510.1449 - Opera est à jour
    Flux de mise à jour : Stable
    Système : Ubuntu 16.04.2 LTS (x86_64; Unity)

    How can I solve this problem ? Thanks !

  • What does your system use as x-www-browser? You can check it with
    $ file /etc/alternatives/x-www-browser
    eg
    $ file /etc/alternatives/x-www-browser
    /etc/alternatives/x-www-browser: symbolic link to /usr/bin/opera

    In short, your problem is: why does discord/slack/gyazo/someotherapp launch this

    "x-www-browser"

    and not this

    "x-www-browser (urlhere)"

    but my english is kinda poor to explain it properly.

  • I kinda see what you mean, I think

    I tried to put Mozilla as a default browser, and yea opening links with Mozilla works fine ...

    Definetly an Opera problem, sadly ...

  • Well, I tried opening a link from skypeforlinux and it did open properly. On the other hand, a link from thunderbird opened in chromium. Skypeforlinux seems to use whatever the x-www-browser is, giving the user no option to change it, while thunderbird allows setting it via about:config. The problem is thunderbird is set to use x-www-browser too.

    Anyway, I would suggest manually setting opera as the x-www-browser (and gnome-www-browser) by

    $ sudo update-alternatives --config x-www-browser

    e.g.

    $ sudo update-alternatives --config x-www-browser
    There are 3 choices for the alternative x-www-browser (providing /usr/bin/x-www-browser).

    Selection Path Priority Status

    • 0 /usr/bin/opera 120 auto mode
      1 /usr/bin/chromium 40 manual mode
      2 /usr/bin/firefox-esr 70 manual mode
      3 /usr/bin/opera 120 manual mode

    I need to learn how to put these in code tags 😞

  • I don't understand, what do you want me to do ? I tried to change the priority status, and it Opera was already selected as Priority ... 😞

  • I suggested you run "sudo update-alternatives --config x-www-browser" and selecting opera from the list, but not the option that says "auto mode" next to it, but the one that says "manual mode".
    I think it is the only option you have in order to "force" the system to use opera.

    Why do I have to wait for my messages to be approved before being posted?