Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera browser does not play twitter videos and gifs again

  • Ok, here is my solution:

    Sorry, but i'm not tested "i386" version, but "amd64" works great.

  • Hi, rudiau1! Yeah, you're right. It was the problem with ffmpeg-codecs.

    It's easy to fix it by reverting back to Opera 42 and ffmpeg 53. I basically downloaded Opera from Tyrion and then used my older guide from here:

    https://forums.opera.com/topic/18564/incompatibility-with-the-latest-chromium-codecs-ffmpeg-extra-in-ubuntu

    Everything works.

  • Hi! Here is solution for Opera 43. (Kubuntu 16.04 x64)

    1. We need to update Chromium browser to 56.0.2924.76 version (Opera 43 use this version of Chrome engine)
    2. Add repository - sudo add-apt-repository ppa:canonical-chromium-builds/stage
    3. Update system - sudo apt update
    4. Chromium must updated to 56 version
    5. As recently as advised tyrion-ua:

    Copy the libffmpeg.so file from the library (/usr/lib/chromium-browser)
    Replace the libffmpeg.so file in the browser folder (/usr/lib/x86_64-linux-gnu/opera) with this file.
    Restart the browser.

    Now Opera plays videos from Twitter, Instagram, etc.

  • The only solution is to wait for a new update in the Opera for Linux browser, which corrects this problem making it unwise to uninstall the updated version from the previous one.

    What is not understood is that being an excellent browser, probably the best of the day, this error in playing videos on Facebook, Twitter, and Tumblr, often comes up giving the idea that even a seeming mistake.

  • Thanks in-tensive! Works correct at 43 version.

  • tyrion-ua,

    It was your idea. I just modified it.

  • Hi! Here is solution for Opera 43. (Kubuntu 16.04 x64)

    1. We need to update Chromium browser to 56.0.2924.76 version (Opera 43 use this version of Chrome engine)
    2. Add repository - sudo add-apt-repository ppa:canonical-chromium-builds/stage
    3. Update system - sudo apt update
    4. Chromium must updated to 56 version
    5. As recently as advised tyrion-ua:
      Copy the libffmpeg.so file from the library (/usr/lib/chromium-browser)
      Replace the libffmpeg.so file in the browser folder (/usr/lib/x86_64-linux-gnu/opera) with this file.
      Restart the browser.
      Now Opera plays videos from Twitter, Instagram, etc.

    Right ON !!
    Thanks

  • Honestly, sometimes I could just kick myself.

    Was trying to download from the above suggested sites and having problems downloading and installing deb packages.

    Anyhoo, for some reason I decided to clean out the Downloads folder and lo and behold there was the

    'opera-stable_42.0.2393.517_amd64.deb' package from when I originally installed Opera.

    So after uninstalling Opera 43 and reinstalling 'opera-stable_42.0.2393.517_amd64.deb' everything works, nothing else required.

    I like to apologize to jgffopera for taking over his post but hopefully it has helped him. I will be book marking this post for future reference that's for sure.

    Thank you all.

  • PS
    Now I just need a 'reload' in the Tab Label right click context menu and I will have the perfect browser. 🙂

  • I resolved the problem by installing the Vivaldi browser.

  • I still use Ubuntu32bit so cannot install Vivaldi or change the libffmpeg.so file because I have /usr/lib/chromium-browser/libffmpegsumo.so.
    If I uninstall Opera 43 & roll back to opera 42.0.2393.517 by downloading again will I lose all my settings etc which are preserved during regular updates? If so I can wait until the next update if Opera fixes this issue.

  • "will I lose all my settings etc"

    No.

    But be safe and backup "/home/rudi/.config/opera"(replace rudi with your directory) then in the event of a mishap simply replace that directory with your backup.

  • PS
    I should have mentioned that is the profile directory and the path can be found at Menu|About Opera.

  • Tried the method posted by @in-tensive above but no luck.

    But finally got it working. For Opera 43.0.2442.806 on Ubuntu Xenial 16.04 I had to:

    • Download the package opera-ffmpeg-codecs-56.0.2924.76-1-x86_64.pkg.tar.xz from https://repo.herecura.eu/herecura/x86_64
    • Extract the libffmpeg.so file
    • Then move it to /usr/lib/x86_64-linux-gnu/opera/libffmpeg.so. Had to use "sudo"

    Do NOT put it inside "/usr/lib/x86_64-linux-gnu/opera/lib_extra".

    Seriously, I don't know why tf the directory changed again in this release or why Opera for Linux has to be so f* complicated.

  • Hi! Here is solution for Opera 43. (Kubuntu 16.04 x64)

    1. We need to update Chromium browser to 56.0.2924.76 version (Opera 43 use this version of Chrome engine)
    2. Add repository - sudo add-apt-repository ppa:canonical-chromium-builds/stage
    3. Update system - sudo apt update
    4. Chromium must updated to 56 version
    5. As recently as advised tyrion-ua:
      Copy the libffmpeg.so file from the library (/usr/lib/chromium-browser)
      Replace the libffmpeg.so file in the browser folder (/usr/lib/x86_64-linux-gnu/opera) with this file.
      Restart the browser.
      Now Opera plays videos from Twitter, Instagram, etc.

    Thank you in-tensive. After a little hokey pokey I got this to work. Thank you for helping me learn a little more about Linux and how to fix this very annoying bug.

  • Thank you in-tensive. After a little hokey pokey I got this to work. Thank you for helping me learn a little more about Linux and how to fix this very annoying bug.

    Not at all, kpsaver.
    I am a fan of Opera Browser and happy to help you.
    Despite some of the problems of our beloved web-browser ;)))))

  • sudo add-apt-repository ppa:canonical-chromium-builds/stage
    sudo apt-get update
    sudo apt-get install chromium-codecs-ffmpeg-extra
    

    It's working. There is no need to move any files

  • Problem solved. Thanks @adasiko

  • I am finding in Facebook animated gifs (and I think some videos) are not working.

Log in to reply