Opera 41+ Flash not showing up/working [Fedora 25] [Linux] [Gnome]

  • I have been trying to install flash on Opera and Opera Developer for about 2 days now after reinstalling Fedora 25 Workstation. On my previous installation Fedora 24 KDE I had opera installed and flash worked fine. However after the upgrade I can't seen to get flash working. I have chrome installed and it's flash works fine which is located @ ~/.config/google-chrome/PepperFlash/23.0.0.207/libpepflashplayer.so, I have tried copying the PepperFlash folder to multiple locations including:
    ~/.config/opera
    ~/.config/opera-developer
    /usr/lib64/chromium/
    /usr/lib64/opera
    /usr/lib64/opera-developer

    I have also tried downloading the version of flash from Adobes webpage and installing it there. For the tar.gz file I tried it in all the same locations. For the RPM I just installed it (That seems to be the firefox version only though so I doubt that makes a difference). I am just really confused why its not showing up and I can't seem to find a way to debug it so I was hoping someone could point me in the right direction

  • Further information: I have also tried deleting and recreating the ~/.config files for opera and chrome, neither has solved the problem. I also changed me to the owner of all the PepperFlash files and still no luck.

  • The same for me since some time, Flash is not working anymore in Opera Developper on Ubuntu 14.04 32 bits. It's still working in Firefox, so that's not an environment issue (I checked the environment is OK anyway).

  • I have also attempted with Opera Stable and I get the same results.

  • I have the same problem and I can't seem to find a solution either

  • You can use this script from ruario https://gist.github.com/ruario/215c365facfe8d3c5071
    It will install the flash player to /opt/google/chrome/PepperFlash/ on my Centos 7.3
    Both Opera 42 and Vivaldi will detect the plugin.
    However it breaks the plugin for google chrome - removed the folder from /home/ocky/.config/google-chrome/PepperFlash/ ... but if you don't use chrome you are OK. You will need to run the script from time to time to get the latest plugin.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.