Google play music doesn't work

  • Google play music doesn't start playing music on my Opera 41.0.2353.30. Pepper flash is install and works correctly on other sites. What can I do with this problem?

  • are you on linux ?

  • Yes, and I found a tendency: music doesn't play because https://r1---sn-hp2u-n8ve.c.doc-0-0-sj.sj.googleusercontent.com/crossdomain.xml returns 404. However, it returns 200 in other browsers and in opera with VPN turned on.

  • I have the same issue and can confirm that link from @greenriverrus returns 404 in opera 41+ but downloads ok even with curl.
    I'm tried to make curl link in developer console:

    curl 'https://r6---sn-gxuog0-bvwe.c.doc-0-0-sj.sj.googleusercontent.com/crossdomain.xml' -H 'Referer: https://play.google.com/music/listen' -H 'User-Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.2883.35 Safari/537.36 OPR/42.0.2393.38 (Edition beta)' -H 'X-Requested-With: ShockwaveFlash/23.0.0.205' --compressed
    

    and it works well, page exists:

    <?xml version="1.0"?>
    <!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
    <cross-domain-policy>
    <allow-access-from domain="s.ytimg.com" />
    <allow-access-from domain="*.youtube.com" />
    <allow-access-from domain="play-music.gstatic.com" />
    </cross-domain-policy>
    

    Last working version of opera-beta: 40.0.2308.52.

  • Addition (can't find how to edit post): this url works well in private window.

  • Finally I found a solution.
    Play Music works again after disabling experimental QUIC protocol here: chrome://flags/?search=quic#enable-quic

  • Thanks, it works!

  • Hi!, i cant hear any sound from Google Play Music, im using Opera browser on a LinuxOS, the: chrome://flags/?search=quic#enable-quic doesn't work on my case, does anyone had an other suggestion? Thanks

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.