U2F stopped working in Opera 41

  • U2F was working in Opera 40 but is not working in 41.

    Version: 41.0.2353.46 - Opera is up to date
    Update stream: Stable
    System: Arch Linux (x86_64; Unknown)

    On fastmail.com, when I get to the two step verification page, the device does not respond when I press the button. Eventually the login times out.

  • Same problem here. I'm trying to sign into Google Apps with a yubikey. Worked in previous version of Opera, but the latest update seems to have broken Fido U2F functionality.

  • I'm experiencing the same issue but on OS X El Capitan. The hardware just never seems to react to the browser's request.

  • I tried the latest minor release in Arch Linux (41.0.2353.56) and the problem is still there.

    Is there any way to know if the Opera devs are working on this?

  • I don't know. I've been experiencing the problem in Windows 10 with Opera. I submitted a bug report, but I don't know if it received any attention (I don't know if it is a priority for them). I think it would be helpful for anyone who is experiencing this issue to submit a bug report, so that a fix can hopefully make it into the next minor release.

  • had the same in beta 41 back then although in beta 42 it works again. (win8.1x64)

    so I think it's more a general problem rather than just unix.

  • It's working for me now also in beta 42. Maybe they'll add it to their regression tests so it doesn't bounce in and out of operation.

  • Also working in minor release 41.0.2353.69.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.