Opera DEV: Logins mit Passwortmanager auf Website bei Auth Basic unmöglich

  • Leider ist die DEV 22 immer noch unbrauchbar bei Logins mit Authentication Basic auf Webservern. Es lassen sich keine Usernamen in der Loginmaske auswählen, falls mehrere Logins für die Domain vorhanden sind.

    Bug DNA-7933 wurde schon 2013 für Opera 15 STABLE gemeldet.

  • [mod edit: bitte beim Thema bleiben]

  • Ich habe mal versucht, das Ganze nachzuvollziehen, bin aber daran gescheitert.
    Ja, der Login wird immer mit dem letzten automatisch aufgefüllt, aber wenn ich das feld lösche, dann bekomme ich alle jemals gespeicherten Logins vorgeschlagen.

  • In der 22.0.1471.8 wird der Loginname samt Passwort jetzt korrekt eingesetzt.
    Das muss wohl gefixt sein.

    Ich habe mal versucht, das Ganze nachzuvollziehen, bin aber daran gescheitert.

    An was gescheitert?

    Ja, der Login wird immer mit dem letzten automatisch aufgefüllt, aber wenn ich das feld lösche, dann bekomme ich alle jemals gespeicherten Logins vorgeschlagen.

    Wenn ich das Loginfeld Benutzername lösche, bekomme ich keinerlei Logins bei Auth Basic vorgeschlagen.

  • Bislang ist das andere Problem, wenn mit zwei verschieden Benutzernamen auf derselben URL einloggen und den Benutzernamen im Loginpopup auswählen, nicht gelöst.

    Wenn Benutzer test1 und test2 auf http //.....de/test/2/ einloggen und die Passwörter gespeichert werden, kann ich die unterschiedlichen Benutzer nicht auswählen wie in Opera 12.

    Bitte Bug DNA-7933 mit zweitem Testcase ansehen 😉

  • Ich hatte den Teil mit dem HTTP-Auth überlesen. Für normale Webseiten-Logins klappt es ja.
    Hab's confirmed. Kann aber sein, dass du es (auch) in Chromium melden solltest. Zumindest wurde mir das bei einem ähnlichen Problem (auch HTTP Auth) geraten (siehe DNA-19756) 😉

  • @christoph142 Hab's confirmed.

    Danke!

    Kann aber sein, dass du es (auch) in Chromium melden solltest. Zumindest wurde mir das bei einem ähnlichen Problem (auch HTTP Auth) geraten (siehe DNA-19756) 😉

    Für Chrom* als Issue 371912 gemeldet

  • Der Bugs mit dem Login ist wohl für Chromiums als auch Operas Devs völlig uninteressant.
    Jedenfalls lebt das Ungeziefer auch noch bei 24.0.1534.0

    😞

  • Ich seh gerade, dass der Bug in Chrom* seit 16.0.898.0 (laut Wikipedia ist das November 2011) nicht gefixt ist, noch nicht mal bislang in Canary, ist ziemlich nervig.
    Dass Opera auf Grund der Anhängigkeit zu Chromium den Bug mitschleppt, nun ja. Das macht Opera 24ff nicht gerade benutzerfreudlich.

  • Bislang keinerlei Fix in Sicht bei Opera?

  • Leider immer noch vorhanden in Dev 27 (Chromium 40) 😞

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.