stuck on Opera 12.16

  • Have been using opera since 3.2, but am starting to look for alternatives.

    Why? I am unable to run any version of Opera newer than 12.16.

    Why? There is some strange dependency (yes, I have verified it by running ldd on the binaries) on gconf. Gconf is deprecated and unmaintained, and the security policy I am operating under no longer allows it to be installed on any system.

    Virtually all of gnome has migrated to gsettings:

    gsettings migration

    I am wondering if there are any plans to remove the gconf dependency in the near future (if not, I am gone).

  • Hi - I don't know if this will help but I just updated from v12 to v39 in Linux Mint 17.3.

    I originally had issues trying to install from a .deb file downloaded from Opera.com and discovered that there was vers 39 available in Synaptic (package manager).

    The direct .deb install looked for dependencies that Synaptic did not.

  • No, it doesn't help.

    Security policies prohibit the installation of gconf on any of my machines - it is deprecated and unmaintained. I refuse to install gconf to run Opera or any other program.

    Yet for some bizarre reason, Opera developers keep linking it in when building Opera, even though it does absolutely nothing as far as running Opera.

  • Is Opera ever going to release a version that doesn't depend on the deprecated gconf? I am stuck on 12.16 until it does (but looking harder at other browsers).

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.