Opening link in new tab issues

  • I'm build up a new Fedora Linux system and playing with it. I have Opera 12.16 running in the old Linux box and needless to say, Opera 36 is different. I'm getting the hang of it, but one thing that I can't seem to find a fix for is getting a link to open in a new tab the same way it does in Opera 12.

    In the old version, I can hold the shift key and click on the link and it will open in a new tab and the focus will go to that tab. Now when I do that it opens a new window. How do I change that?

    And before you say to right-click on the link and select "Open link in a new tab," that doesn't work correctly either. Yes, it opens the link in a new tab, but the focus stays in the current tab.

    Any points in getting this to work will be appreciated.

  • Hi @mrvideo, hold down Ctrl+Shift, and click the left mouse, or hold down the Shift key, and click the middle mouse, to open a link in a new tab in the foreground 😉

    You can also use a mouse gesture (Move down) - to enable it, go to Settings > Browser > Shortcuts, and tick the checkbox on the left of "Enable mouse gestures".

  • Thanks, the middle mouse button trick works. Going to have to get used to that, as I still have the old Linux running with Opera 12.16. Not sure why that shortcut with the mouse would be changed.

    As for the move down trick, that does not work. When I click and hold on the link and move the rodent down, all that happens is that I see the link text and the link itself in a gray box that moves with the pointer. Clicking and holding on an empty space and moving down highlights the text.

  • @mrvideo It's right-click 😉 I'm sorry, I forgot to mention, that "Mouse gestures work by holding the right mouse button, moving the mouse a certain direction, then letting go of the button." - you can find more details here.

  • Thanks. I went back to the "learn more" and now see that. My eyes went to the section that started with the bold letters regarding mouse gestures and there was nothing there about using the right button. Then I looked above that line and there it was. Suggestion: put that statement below the bold line.

    Oh, yep that worked.

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.