Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Hello,

    The upgrade to 34 broke my ability to view Flash with Opera. The recommended solutions that worked with 33 and earlier versions no longer work. Chrome, PepperFlash, ect all installed and working with other browsers. Any thoughts on how to fix? I can see Flash with Chrome, Chromium and Firefox.

    Please do not reply with "Move to HTML5.", etc... There are several resources I need that will continue to require Flash for the foreseeable future.

    Thanks in advance,

  • What site are you having problems with

  • At last I found the solution, at least for people using the pepperflash plugin from ubuntu.

    During installation of ubuntu gnome in October I added a repository (I cannot find the instructions anymore) that made the pepperflash plugin available as a separate package. This package does not seem to update, probably because the repository I added does not update.

    But in a feature request for automatic updates I found the instruction to use some commands to update the plugin:

    So, If you use this repo for the pepperflash plugin:

    Just write:
    update-pepperflashplugin-nonfree --install


  • Hello bbands,athlonite, and tandreass1.

    I'm having a similar problem in Peppermint 6. Updating went fine for Chromium browser, but it had no effect whatsoever on Opera 34. Adobe Flash Player should be Version: (Shockwave Flash 20.0 r0) and not:

    Adobe Flash Player
    Version: 99.999.999.999
    Shockwave Flash 99.999 r999
    PPAPI (out-of-process)

    I don't know what to do about this. I tried disabling and re-enabling, logging out and then in, but nothing fixed this problem. My situation is the same as bbands, I need Flash every now and then, and I know what I'm seeing isn't right here.

    I'm stumped! Any potentially constructive suggestions would be appreciated.

    Thank you,



    I reported this problem to Peppermint too. PCNetSpec said that Peppermint had a the same problem there "with Chromium not being able to correctly extract/report the pepperflash version, so it defaults to 99.999.999.999" He said, "That's not a functionality problem, just a reporting issue...."

    We hope this link helps the team at Opera do something similar.

    This link helps explain what Team Peppermint did to resolve this issue for Chromium browser.,2935.msg29027.html#msg29027

    Here are the contents of our /etc/chromium-browser/default:

    part for pepperflashplugin-nonfree : begin


    if [ -f $flashso ]
    flashversion=strings $flashso|grep ^LNX|sed -e "s/^LNX //"|sed -e "s/,/./g"
    CHROMIUM_FLAGS="$CHROMIUM_FLAGS --ppapi-flash-path=$flashso --ppapi-flash-version=$flashversion"

    part for pepperflashplugin-nonfree : end

    We hope our friends here at Opera will find this information helpful.

    perknh (with the knowledge and experience of PCNetSpec himself!)