Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Mail outbox of Opera 12.16 is broken

  • I'm running Opera 12.16 on Ubuntu Linux.

    My Opera Mail worked fine with the current setup, but now - all of a sudden - my outbox is broken. 😞

    With my configuration, mails were queued in the outbox before they were being sent. However, this mechanism does not work anymore. As soon as I hit the 'Send' button, the mail window is closed and the message completely disappears. It is neither stored in the outbox nor is it being sent directly. It's simply gone.

    When I change my configuration, so that Opera sends mails directly (no outbox involved), it works without any problems. The mail is sent directly and moved to the sent folder afterwards.

    However, I want to use the outbox (enqueuing enabled) , so I can edit outgoing mails within a certain timeframe. Since this used to work before, I wonder what broke my Opera and how I can fix that.

    Did anybody experience this problem as well? How can I fix it? Are there any lock files or folders I can check? I suppose Opera crashed and is now in some sort of irregular state. Any help is greatly appreciated.

  • Hello actron,
    What you describe sounds pretty much like what I experienced some time back with 12.16 on Fedora.
    If I remember correctly I couldn't find a solution other than disable queueing, which works OK for me.
    I have got myself into the habit of not sending as soon as I finish writing the email, so stays as a draft, which I check later, then send.


  • On the toolbar above the message list for "All Messages/Outbox", click the "Settings for this view" icon and make sure "Sent" is checked under "Show" to ensure messages show in the Outbox.

    However, since you said queued messages aren't being sent, that probably won't help. But, try it just in case.

    Also, check the log to see if Opera even attempts to send them. Sounds like it doesn't.

    Also, while Opera is closed, check accounts.ini in the mail folder. Make sure the setting to queue messages for the account is indeed set to 1 (for on) and not some weird number that might confuse Opera.

    Or, launch opera with the -pd "path to folder" option and set up the account in it. If POP, do not uncheck "leave messages on server". See if queuing messages works fine in it. If so, there's something funky with your original profile. Might be operaprefs.ini (which you can close down Opera and rename it). It might be in the sessions folder. Or, it could just be something messed up in the "mail" folder where you'd have to start with a new mail folder to fix things.

  • I enabled logging, but no outgoing log file is ever created. Incoming log file was created right away.

    So it seems like Opera discards my new mail immediately, so it won't even attempt to send it. As noted before, no mail will show up in the outbox.

    I also tried creating a second mail account within Opera, but they seem to share their outbox folder. So the same problem applied to the newly created account as well. Opera wont even let it create a mail in the outbox.

    Maybe there is some user rights problem in the file system? Does anybody know where outgoing mail is stored? In index.ini there is a m2_outbox.idx mentioned, but I could not find that file anywhere (same appies for all the other m2_*.idx files like m2_draft.idx).

  • Maybe there is some user rights problem in the file system?

    Could be. I'd assume that as long as your user account has read AND write access to Opera "mail" folder (and all foldres and files in it), you should be fine.

    Have you messed with your HOSTS file at all? Do you have any hostnames in the file with invalid characters?> I also tried creating a second mail account within Opera

    I would try the -pd switch option to rule out a corrupted profile.

    If none of that helps, maybe it's a lib version issue. I think you can start Opera with a debug switch, which might give more info in the console.