How to install, and run the Opera 20 for Windows, under Linux box, using the Wine app.

  • This tutorial is for testing, and research purposes, and shows, how one can install, and run the Opera 20 for Windows, on Linux boxes, using the Wine application. You should be also aware, that it is intended for a bit more advanced Linux user, and not for the ordinary user of this os.

    1. Download latest Opera 20, run the installer, and click the "Options" button:

    Opera 20 options

    Within the next window select your language, then choose the path on the right of the "Install path", e.g. "C:\Program Files\Opera20usb", and then select the "Stand-alone installation (USB)" within the selectbox on the right of the "Install for", then click the "Accept and Install" button:

    Opera 20 select installation options

    1. After installation, the Opera should launch automatically - close it, and then connect the usb stick (or portable hard drive) to your computer. Create a directory on the usb stick, eg "opera20usb", and then create the "profile" subdir, and then create the "data" subfolder in it. Go to the installation root (which was selected in step 1), and copy the "20.0.1387.64" directory, to the "opera20usb" on your usb drive, then go to the "...opera20usb\profile\data", and copy the "dictionaries" folder, the "Local State", and the "Preferences" files, to the "data" subfolder on your usb drive.
    1. Run the Linux box (small note: there must be installed the Wine apps), connect your usb drive, and copy the "opera20usb" directory, to the "Program Files" subfolder in the Wine user profile directory: "~/.wine/drive_c/Program\ Files/",
    1. To start the Opera under Wine, we need the "bcrypt.dll" - Windows cryptographic primitives library (Wow64). You can download the zip archive from here, then unpack the "bcrypt.dll" file, and then copy it to the "~/.wine/drive_c/windows/system32/" subdir, then go to the shell (bash/sh), and run the "winecfg" command, and then click on "Libraries", and go to the input field, under the "New override for library", and enter "bcrypt.dll, and then click on "Add" button, on the right, then click the "Edit" button, and select the "Native (Window)" within the pop-up window, and then click the "OK" button, and then click "Apply", and click "OK", to close the "winecfg":

    Winecfg adding "bcrypt.dll" native

    1. If you want to use the Flash plug-in in the Opera under Wine, you can download the latest installer from here, and install it as below: open the shell, and type: "wine install_flash_player_12_plugin.exe", and press enter.
    1. The final step, before the run the Opera, is to create the startup script. Open your favourite text editor, and add the lines as below:
    #!/bin/bash
    cd ~/.wine/drive_c/Program Files/opera20usb"
    /usr/bin/wine launcher.exe --no-sandbox --ppapi-startup-dialog --disable-gpu &>/dev/null
    

    Save it as, eg "opr20-launcher.sh", close the file, and give it executable permission as follows:
    "chmod 750 opr20-launcher.sh".

    1. Now you can run the Opera as follows: go to the shell, change to the directory which includes the "opr20-launcher.sh", and enter "./opr20-launcher.sh", and press enter, which should launch the Opera. Now go to the address bar, and type "opera:plugins", and press enter, under the "Adobe Flash Player" click the "Enable" button, to enable the plug-in:

    Opera 20 enable Adobe Flash plug-in

    That's all - wish you good luck with testing the Opera 20 under the Linux box 😉

    Tux

  • Additional notice: to launch the latest Opera 21 (currently version 21.0.1432.5) for Windows under Linux (using Wine) by following the above steps, you no longer need to add the " --disable-gpu" switch, you can run the Opera 21 as follows:

    /usr/bin/wine launcher.exe --no-sandbox --ppapi-startup-dialog &>/dev/null
    

    Therefore, one can edit the launch script for the Opera 21, and safely remove this switch.

    Of course, can still be the graphics card, for which the graphics hardware acceleration is not supported yet in this version of Opera 21, and in that case (when you will see a black screen), you need to reedit the launch script, and add the switch back.

  • I followed your directions on kubuntu 14.04 using wine1.7.14 but there is no window, but "welcome to opera" window bar is shown

  • One important correction (forgot to mention, please excuse me) - you need to copy also three files from main installation dir: go to the installation root (mentioned in step 1), and copy the "installation_status.xml", installer_prefs.json", and "launcher.exe", to the "opera20usb" on your usb drive, and then copy these files to the "...Program Files/opera20usb" (mentioned in step 3) in the Wine user profile directory on your Linux box.

  • Next notice: you can update the Opera 20 to the latest build 20.0.1387.77, which includes few important fixes.

  • there is no window, but "welcome to opera" window bar is shown
    Hi Ukbeast, I think, that I know, what can cause the issue in your case: lack of one or two, preconfigured sections in the "Preferences" file, which should include lines as below:

    {
       "browser": {
          "window_placement": {
             "height": 327,
             "left": 46,
             "maximized": true,
             "top": 28,
             "width": 761
          }
       },
       "session": {
          "restore_on_startup": 5
       }
    }
    

    In addition, if one answered the question about statistics, then the file should include also the "statistics" section, as below:

    {
       "browser": {
          "window_placement": {
             "height": 327,
             "left": 46,
             "maximized": true,
             "top": 28,
             "width": 761
          }
       },
       "session": {
          "restore_on_startup": 5
       },
       "statistics": {
          "collection_asked": true,
          "collection_enabled": false
       }
    }
    

    I hope, that this will help to solve the problem 😉

  • One correction of the mistake in the launch script, please replace the line:

    cd ~/.wine/drive_c/Program Files/opera20usb"
    

    with this:

    cd ~/".wine/drive_c/Program Files/opera20usb"
    

    or with this - it also works:

    cd ~/.wine/drive_c/Program\ Files/opera20usb
    
  • Thanks mate 😄
    My findings:

    1. flash works but is slow due to no hardware acceleration (intel b820 integrated GPU)
    2. Divx web plugin does not work
    3. fonts are rough
      4 HTML5 youtube full-screen does not work.
  • You're welcome 😄

    Additional progress: regarding the GPU hardware acceleration, and the problem with a black screen.

    Try to remove the "--disable-gpu" switch in the launch script, and replace it with "--disable-gpu-compositing". After this change, the Opera should work also well, and even better for most GPUs.

    Launch the Opera, go to the address bar, and type "opera:gpu", and press enter. Here, on my Linux box, the statuses for almost all graphics functions are in green 😉

  • I think it's easier to use a VM. Microsoft offers images on http://modern.ie

  • Hi Frenzie, nice to see you also here 😉

    Yep, I already installed several instances of the virtual machines (e.g. VMware Player, Oracle VM VirtualBox), I have all of the Opera's streams installed there, and I'm experimenting with them from time to time, nevertheless I thought, that I can also try, a bit more native Linux solution, and a little more close to the Open Source like Wine, instead to use licensed M$ software 😉

  • Great guide, thank you. But https does not work. You can solve this problem?

  • Hi, you're welcome 😉 Which version of Wine? Here it works without problem, for example encrypted google, opens without issues.

  • Hi l33t4opera,

    Opera
    Version: 20.0.1387.91
    Update stream: Stable
    System: Windows XP 32-bit
    Browser identification
    Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/33.0.1750.154 Safari/537.36 OPR/20.0.1387.91

    Wine 1.6.1

  • just tried another version of wine (1.7.17), it's works!, thanks!

  • I'm glad, that you made it, congrats 😉

Log in to reply
 

Looks like your connection to Opera forums was lost, please wait while we try to reconnect.