Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera 31 broke the compatiblity with ffmpeg in Ubuntu 14.04

  • @avl:

    Can't you use the implementation of ffmpeg that Firefox use? (OpenH264)

  • @avl:
    Can't you use the implementation of ffmpeg that Firefox use? (OpenH264)

    We could use it as an alternative H264 decoder, but notice that OpenH264 is definitely not an implementation of ffmpeg :).

    It's a completely different library, and maintaining a video pipeline that uses it would be lots of work (look up how long it took Firefox to integrate it; in terms of Opera, it would be similar to the work needed on Windows and Mac to integrate with their system libraries). In addition, it doesn't solve our problems: although it's able to decode some H264 videos, it doesn't play all profiles, and it doesn't decode any audio, so for most videos you'd still be out of luck. It would be less work (and more rewarding) to try and use the system ffmpeg again.

  • Okay.

    (Excuse me, implementation was not the right term. It's perhaps more of a variant.)

  • I have the same problem in my Antergos (Arch-based).

    I hope for a definitive solution soon.

  • Trying to make Firefox run 1080p 60fps videos on Linux (since MSE is not full implemented in Firefox, it can't reproduce 1080p 60fps videos with VP9, this happens on Windows too), I discover that Firefox uses some libs (libav) that are installed with VLC to play 1080p 60fps videos with MP4 codec. So Opera could do the same? @avl

  • @sidneyneto

    Firefox uses gstreamer (may be libav over gstreamer)
    And libav is fork of ffmpeg.
    So there's no reason for this ...

  • @avl

    As a lark I tried it with the Opera beta build and can confirm that it worked. Rather nifty. Thanks for the fix.

  • https://help.ubuntu.com/community/OperaBrowser

    Updated

    • Instructions on how to fix H.264 support.
  • https://help.ubuntu.com/community/OperaBrowser
    Updated

    Instructions on how to fix H.264 support.

    I like that, thanks. I've added it to my bookmarks because I'm pretty forgetful. It works with the beta and dev versions just fine AFAIK. I used a marginally different process but it worked well enough. I've lately been poking at Lubuntu and have been pretty happy so I think I'll stick to this distro for a little while though I'll surely move on to another one soon enough.

  • The newest release of Opera beta 33.0.1990.35 is now able to detect whether the chromium-codecs-ffmpeg-extra package is installed. When it is installed Opera can use it to provide support for some proprietary codecs for media elements, including H264 and MP3.

    http://blogs.opera.com/desktop/2015/10/opera-beta-33-0-1990-35-update/

    As per blog post the package must be up-to-date (45.0.2454.x and newer). Looking at Ubuntu repos it seems that all currently supported releases have that package up-to-date.

Log in to reply