Turns out this is caused by a change in Chromium. See https://bugs.chromium.org/p/chromium/issues/detail?id=1358542 for more info. The issue is fixed. Just have to wait for Opera to include the new version of Chromium with the fix. Until then, you can launch Opera like this:

"C:\Program Files\Opera\launcher.exe" --disable-blink-features=MediaSourceInWorkersUsingHandle

(adjust the path to your Opera's launcher.exe)
to work around it.