Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera lock up randomly every 5 to 10 seconds (66.0.3515.27)

  • Does this solution have the same limitations )or drawbacks, imho) that the snap versions of any app has?
    Because they (= the snap apps_ run in a sandboxed enviroment, they need special permissions to access the filesystem and other system stuff, they launch slower than regular apps and a couple more I can not remember now.

  • @jimunderscorep Firejail allows you to configure access but default profile only allows access to downloads folder. No impact on speed and the over all system including the xorg is full safe and protected from any 0 day exploits.

  • Fresh install 19.3 Tricia (Mate) and brand new install of Opera, so it's the latest version. Mine freezes every 5 seconds or so. It still must be logging keystrokes and mouse clicks even though the screen is frozen. All I have to do is mouse over the "Easy Setup" button in the upper right and instantly everything I typed will appear or my mouse click will execute, pages will scroll, etc.

    Does this on every web page I visit, no logic to it, just does it constantly no matter what. I have no other browser on my system.

    I really need this to work. My ISP service is 500mbps up and down, and Opera is the only browser that lets me achieve any internet speed faster than 150mbps. Unfortunately, Firefox and Chrome are the only browsers I have tried (and removed) that do not ever freeze, but they are both incredibly slow and both keep my cpu pegged at 100%. When I use Opera the internet speed test will come back at 350mbps. But this constant freezing and mousing over the Easy Setup button makes Opera unusable for me.

    This is such a pervasive issue for so many people I'm surprised that it isn't getting more urgent interest from the developers.

  • I'm having the same issue. I have disabled HA, which does seem to help a little but not cure the issue. In fact this is the second time I have tried to switch my browser to Opera, the same issue forced me over to Firefox for the past year or so. Hard to believe both the video player issue and these lock-ups are still a problem! The 'easy setup' trick is handy to know, but not very convenient when using a trackpad. I have pasted my machine details below:

    System:    Host: ideapad Kernel: 5.3.0-40-generic x86_64 bits: 64 gcc: 7.4.0
               Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu4) dm: lightdm Distro: Linux Mint 19 Tara
    Machine:   Device: laptop System: LENOVO product: 81A5 v: Lenovo ideapad 120S-14IAP serial: N/A
               Mobo: LENOVO model: LNVNB161216 v: SDK0J40700WIN serial: N/A
               UEFI [Legacy]: LENOVO v: 6GCN20WW X64 date: 08/15/2017
               Chassis: type: 10 v: Lenovo ideapad 120S-14IAP serial: N/A
    Battery    BAT1: charge: 31.1 Wh 100.2% condition: 31.1/32.2 Wh (96%) volts: 8.6/7.5
               model: LENOVO BASE-BAT serial: <filter>status: N/A
    CPU:       Quad core Intel Pentium N4200 (-MCP-) arch: N/A cache: 1024 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8755
               clock speeds: min/max: 800/2500 MHz 1: 1199 MHz 2: 941 MHz 3: 995 MHz 4: 1005 MHz
    Graphics:  Card: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Integrated Graphics Controller
               bus-ID: 00:02.0 chip-ID: 8086:5a84
               Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1366x768@60.06hz
               OpenGL: renderer: Mesa DRI Intel HD Graphics 505 (Broxton)
               version: 4.5 Mesa 19.2.8 (compat-v: 3.0) Direct Render: Yes
    Audio:     Card Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
               driver: snd_hda_intel bus-ID: 00:0e.0 chip-ID: 8086:5a98
               Sound: Advanced Linux Sound Architecture v: k5.3.0-40-generic
    Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
               driver: ath10k_pci bus-ID: 02:00.0 chip-ID: 168c:0042
               IF: wlp2s0 state: up mac: <filter>
               Card-2: Atheros usb-ID: 001-002 chip-ID: 0cf3:e500
               IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
    Drives:    HDD Total Size: 128.0GB (72.5% used)
               ID-1: /dev/sda model: RTITF128PCA1MADL size: 128.0GB serial: <filter>
    Partition: ID-1: / size: 20G used: 14G (75%) fs: ext4 dev: /dev/sda1
               ID-2: /home size: 9.8G used: 6.1G (65%) fs: ext4 dev: /dev/sda6
               ID-3: swap-1 size: 4.29GB used: 0.69GB (16%) fs: swap dev: /dev/sda3
    RAID:      System: supported: N/A
               No RAID devices: /proc/mdstat, md_mod kernel module present
               Unused Devices: none
    Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A
    Repos:     Active apt sources in file: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-bionic.list
               deb http: // bionic main
               deb-src http: // bionic main
               Active apt sources in file: /etc/apt/sources.list.d/megasync.list
               deb https: // ./
               Active apt sources in file: /etc/apt/sources.list.d/nathan-renniewaldock-flux-bionic.list
               deb http: // bionic main
               deb-src http: // bionic main
               Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
               deb http: // tara main upstream import backport #id:linuxmint_main
               deb http: // bionic main restricted universe multiverse
               deb http: // bionic-updates main restricted universe multiverse
               deb http: // bionic-backports main restricted universe multiverse
               deb http: // bionic-security main restricted universe multiverse
               deb http: // bionic partner
               Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
               deb https: // stable non-free #Opera Browser (final releases)
               Active apt sources in file: /etc/apt/sources.list.d/tor.list
               deb https: // bionic main
               deb-src https: // bionic main
    Info:      Processes: 261 Uptime: 1 day Memory: 2463.5/3570.5MB
               Init: systemd v: 237 runlevel: 5 Gcc sys: 7.4.0 Client: Unknown python3.6 client inxi: 2.3.56
  • I have the same problem under VirtualBox and Mint 19 as Guest. Opera is not usable anymore. It constantly freezes. On my native devices the bug does not appear.

  • @thomas-rager I agree that Opera is not useable in its current state. I have reverted to Firefox, again, which is a shame because the inbuilt Opera VPN service is brilliant.

  • @thomas-rager said in Opera lock up randomly every 5 to 10 seconds (66.0.3515.27):

    I have the same problem under VirtualBox

    Today I searched the VirtualBox bugtracker for my - as I guess - related problem, because VB throws an exception and kills the running machine (Host Win10, guest Solus), whenever I close Opera. Sometimes even when I close a tab, but I've had no Opera lags with my current settings that time.

    I found something with a suggested workaround (to avoid the crashes) that told me to disable the checkbox in the VB settings which switches the 3D support on. So I did.

    Result: no more crashes, but the annoying lags again.


  • @robomike

    I tried to disable hardware acceleration. I did this in VirtualBox and also tried the Opera setting. Did not fix my problem.
    I think the problem is related to this sandbox issue...

  • @thomas-rager : no, the problem returned for me after disabling hardware acceleration in VB. But the permanent crashes of the whole VM stopped.

    Well - a new strange observation, is anyone able to confirm?

    When I open the "Taskmanager" (Opera menu, developer Tools, key shortcut "shift-escape") and let it run, even in the background, then the lags and locks seem to be significantly shorter. But only as long as the "Memory Usage"-Tab is activated... seriously?

  • @robomike Weird, but true! The lock-ups still occur, but less frequently, and probably shorter too. I wonder if any of the Opera techies are reading this thread, or are we wasting our time?

  • @Northnet Ahh! I have an Opera update waiting. 67.0.3575.31. I will update now and see what happens...

  • @Northnet I believe this is a eureka moment! Ran the update to 67.0.3575.31 and... no more lockups. At least, not in the 5 minutes since opening Opera after the update.

  • @Northnet
    Not helpful for me yet, as I'm using LM 19.3 Tricia and my desktop is Mate 1.22.2 and
    base is Ubuntu 18.04 bionic. When I click on the button to check for Opera updates it tells me my version 66.0.3515.103 is already up to date.

    Maybe I have to uninstall and download again and see if I get a newer version.

  • Well, now I am very hopeful! I followed @Northnet 's lead and manually downloaded and installed the latest version 67.0.3575.31 (after doing a complete removal using synaptic package manager).

    I have been surfing and browsing now for almost an hour with no freezing and no lockups!

    It was interesting that I had to manually download the latest package from the Opera web site and use gdebi package installer to install it before Opera recognized it as an update. When I tried to use Software Manager it told me there were missing dependencies and packages required that would not be installed, etc. So I closed that and played a hunch by using the gdebi package installer, and it seems to have worked fine. It even said all dependencies were satisfied.

    So far so good!

    THANK YOU Opera devs for attention to this issue! Time to import bookmarks!

  • I have small freezes yet after update to Opera 67. This happens on some page with heavy content.

  • Some time after the update to 67, I can confirm that my issues are completely resolved. This is my low power (Pentium - 4Gb RAM) browsing laptop, and not only is it not freezing, but responsiveness is distinctly better. Better than Firefox on the same machine, and feeling positively 'snappy'.

    @pindos If page content is causing a problem, I think maybe it is time to consider your local resources. Lagging processor, insufficient memory, cache waiting for disk to catch up, that sort of thing?

  • The latest Opera fixes the issue and works with sandbox.

  • 24 hours of intensive browsing and no more freezing for me.

  • Opera still freezes on my system if not started with "--disable-seccomp-filter-sandbox" option. But when I want to add some more security to it using Firejail and AppArmor, Opera is not saving any settings! Every start gives me a welcome window and I have to reconfigure it again. I don't have the time and patience and I've switched to Vivaldi for now. It works perfectly with

    firejail --apparmor /usr/bin/vivaldi-stable --disable-seccomp-filter-sandbox %U
  • With the newest Opera version the freezes are gone in the VM. Sadly is this version constantly freezing/crashing on my Thinkpad with Linux Mint 19.3. I don't know if the Devs at Opera are testing their Linux build proper. But this is really annoying. In the VM I will use the latest Version and on my Thinkpad I will stay with 66.0.3515.72 and the ffmpeg fix.