Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Opera lock up randomly every 5 to 10 seconds (66.0.3515.27)

  • @zalex108 said in Opera lock up randomly every 5 to 10 seconds (66.0.3515.27):

    But did you tested to allow whether is related to your settings or it's a Bug?

    Testing won't be proper if it lasts 1 hour, but 4-5 days with the same usage. And in order to use it for all that time, I will have to export and import all my 500+ bookmarks, re-login to forums, github, fb etc I use daily (15+ sites), reinstall all the addons (4) I have and finally reconfigure the browser (= change more than half of the settings) because it's stock settings are way too... uncomfortable for me. Is there anyhing else I missed?

    I estimate that this will take me ~1 hour, but if I am going to do all that, why not move to another browser after all? The cause of that bug is not my (or any other user's) fault.

  • @jimunderscorep


    Actually, you (all) should do periodical backups to avoid problems.
    This is for Opera and the rest of software you use the most and the system as well.

    If you prefer another browser, go, you will need to do the same if not already.

    You could rebuild the Opera profile but during a week if you prefer, instead of all once.

    If you never did it, then it will allow you to know what you need to back up and setup.

    You can also create a Basic profile with the most default settings for other profiles and another for the Default profile with all the custom settings.

    Back them up.

    Start browsing.

    If at some point you face another problem needing to rebuild, half or more will be already done.

    You can create Shortcuts to avoid changing Profile names every time you have to work with one Profile or another.

  • Try to turm off GPU aceleration

    Settings -> Browser -> Use hardware acceleration when available

    PS: I did not notice such problem on Ubuntu 18.04 + Nvidia 435

  • @adasiko

    Hi, I tried disabling hardware acceleration and the issue persists, although it is not as often, so I can actually play lichess, watch youtube, and when I notice imagery locked up, I just click the menu open/close... Ohh the things we do when we love Opera...

  • There were problems after the upgrade GCC 9.2.1. Helped me over Wayland

    opera --disable-seccomp-filter-sandbox
  • @operka4 said in Opera lock up randomly every 5 to 10 seconds (66.0.3515.27):

    opera --disable-seccomp-filter-sandbox

    This tweak is working here so far on Arch and Opera latest.

  • @noel62 I tried Chromium for Linux and the problem persists but not as bad as on Opera were the whole window just locks up. It seems to be a Chrome-based issue.

  • Does this "tweak" have any sideffects on opera's performance and/or security?

    As for the hardware acceleration in opera, I have it disabled here and it makes no difference on this issue if it is on or off.

  • @jimunderscorep said in Opera lock up randomly every 5 to 10 seconds (66.0.3515.27):

    Does this "tweak" have any sideffects on opera's performance and/or security?

    As for the hardware acceleration in opera, I have it disabled here and it makes no difference on this issue if it is on or off.

    it basically disables the sandboxing feature so I suggest using it with Firejail and apparmor, even with sandbox turned on I advise Firejail/apparmor combo as its far safer.

  • @arup65
    So I won't use it. I am a simple user, I do not have time for all that "added security" stuff.

  • This... month-long issue of opera has just cost me some 20+ minute work that I am not willing to do again anytime soon. Now that I have stopped swearing, I can tell you what happened

    I was filing an issue report on a project on github and opera froze for the usual 5-10 seconds the first time. I did not bother and continued when it got unstuck. The second time it froze, it froze completely, leaving nothing but a blank window, not responding to anything! Even the O-menu was gone!
    So, I killed it with killall and relauched it, losing all my 30+ lines of writing on github. I only had 2 tabs open at that time, github's and pastebin's, so I do not think it was a resources or a js issue.

    Since there has been no REAL progress from opera's side on solving that freezing issue, I promise to leave the browser and close my account here if it happens again and costs me work. Thank you.

    p.s. I put "real" in all caps because using the suggested flag is more of a workaround than a solution, due to the security impact it has on my (and on anyone's) system.

  • @jimunderscorep I totally understand your frustration but the solution of Firejail I suggested combined with Apparmor is totally viable even with sandbox in Opera disabled as they fix it but best part is what Firejail does to overall security of the system and its not hard to implement it either.

  • Does this solution have the same limitations )or drawbacks, imho) that the snap versions of any app has?
    Because they (= the snap apps_ run in a sandboxed enviroment, they need special permissions to access the filesystem and other system stuff, they launch slower than regular apps and a couple more I can not remember now.

  • @jimunderscorep Firejail allows you to configure access but default profile only allows access to downloads folder. No impact on speed and the over all system including the xorg is full safe and protected from any 0 day exploits.

  • Fresh install 19.3 Tricia (Mate) and brand new install of Opera, so it's the latest version. Mine freezes every 5 seconds or so. It still must be logging keystrokes and mouse clicks even though the screen is frozen. All I have to do is mouse over the "Easy Setup" button in the upper right and instantly everything I typed will appear or my mouse click will execute, pages will scroll, etc.

    Does this on every web page I visit, no logic to it, just does it constantly no matter what. I have no other browser on my system.

    I really need this to work. My ISP service is 500mbps up and down, and Opera is the only browser that lets me achieve any internet speed faster than 150mbps. Unfortunately, Firefox and Chrome are the only browsers I have tried (and removed) that do not ever freeze, but they are both incredibly slow and both keep my cpu pegged at 100%. When I use Opera the internet speed test will come back at 350mbps. But this constant freezing and mousing over the Easy Setup button makes Opera unusable for me.

    This is such a pervasive issue for so many people I'm surprised that it isn't getting more urgent interest from the developers.

  • I'm having the same issue. I have disabled HA, which does seem to help a little but not cure the issue. In fact this is the second time I have tried to switch my browser to Opera, the same issue forced me over to Firefox for the past year or so. Hard to believe both the video player issue and these lock-ups are still a problem! The 'easy setup' trick is handy to know, but not very convenient when using a trackpad. I have pasted my machine details below:

    System:    Host: ideapad Kernel: 5.3.0-40-generic x86_64 bits: 64 gcc: 7.4.0
               Desktop: Cinnamon 3.8.9 (Gtk 3.22.30-1ubuntu4) dm: lightdm Distro: Linux Mint 19 Tara
    Machine:   Device: laptop System: LENOVO product: 81A5 v: Lenovo ideapad 120S-14IAP serial: N/A
               Mobo: LENOVO model: LNVNB161216 v: SDK0J40700WIN serial: N/A
               UEFI [Legacy]: LENOVO v: 6GCN20WW X64 date: 08/15/2017
               Chassis: type: 10 v: Lenovo ideapad 120S-14IAP serial: N/A
    Battery    BAT1: charge: 31.1 Wh 100.2% condition: 31.1/32.2 Wh (96%) volts: 8.6/7.5
               model: LENOVO BASE-BAT serial: <filter>status: N/A
    CPU:       Quad core Intel Pentium N4200 (-MCP-) arch: N/A cache: 1024 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 8755
               clock speeds: min/max: 800/2500 MHz 1: 1199 MHz 2: 941 MHz 3: 995 MHz 4: 1005 MHz
    Graphics:  Card: Intel Celeron N3350/Pentium N4200/Atom E3900 Series Integrated Graphics Controller
               bus-ID: 00:02.0 chip-ID: 8086:5a84
               Display Server: x11 (X.Org 1.19.6 ) drivers: modesetting (unloaded: fbdev,vesa)
               Resolution: 1366x768@60.06hz
               OpenGL: renderer: Mesa DRI Intel HD Graphics 505 (Broxton)
               version: 4.5 Mesa 19.2.8 (compat-v: 3.0) Direct Render: Yes
    Audio:     Card Intel Celeron N3350/Pentium N4200/Atom E3900 Series Audio Cluster
               driver: snd_hda_intel bus-ID: 00:0e.0 chip-ID: 8086:5a98
               Sound: Advanced Linux Sound Architecture v: k5.3.0-40-generic
    Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
               driver: ath10k_pci bus-ID: 02:00.0 chip-ID: 168c:0042
               IF: wlp2s0 state: up mac: <filter>
               Card-2: Atheros usb-ID: 001-002 chip-ID: 0cf3:e500
               IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
    Drives:    HDD Total Size: 128.0GB (72.5% used)
               ID-1: /dev/sda model: RTITF128PCA1MADL size: 128.0GB serial: <filter>
    Partition: ID-1: / size: 20G used: 14G (75%) fs: ext4 dev: /dev/sda1
               ID-2: /home size: 9.8G used: 6.1G (65%) fs: ext4 dev: /dev/sda6
               ID-3: swap-1 size: 4.29GB used: 0.69GB (16%) fs: swap dev: /dev/sda3
    RAID:      System: supported: N/A
               No RAID devices: /proc/mdstat, md_mod kernel module present
               Unused Devices: none
    Sensors:   System Temperatures: cpu: 42.0C mobo: N/A
               Fan Speeds (in rpm): cpu: N/A
    Repos:     Active apt sources in file: /etc/apt/sources.list.d/danielrichter2007-grub-customizer-bionic.list
               deb http: // bionic main
               deb-src http: // bionic main
               Active apt sources in file: /etc/apt/sources.list.d/megasync.list
               deb https: // ./
               Active apt sources in file: /etc/apt/sources.list.d/nathan-renniewaldock-flux-bionic.list
               deb http: // bionic main
               deb-src http: // bionic main
               Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
               deb http: // tara main upstream import backport #id:linuxmint_main
               deb http: // bionic main restricted universe multiverse
               deb http: // bionic-updates main restricted universe multiverse
               deb http: // bionic-backports main restricted universe multiverse
               deb http: // bionic-security main restricted universe multiverse
               deb http: // bionic partner
               Active apt sources in file: /etc/apt/sources.list.d/opera-stable.list
               deb https: // stable non-free #Opera Browser (final releases)
               Active apt sources in file: /etc/apt/sources.list.d/tor.list
               deb https: // bionic main
               deb-src https: // bionic main
    Info:      Processes: 261 Uptime: 1 day Memory: 2463.5/3570.5MB
               Init: systemd v: 237 runlevel: 5 Gcc sys: 7.4.0 Client: Unknown python3.6 client inxi: 2.3.56
  • I have the same problem under VirtualBox and Mint 19 as Guest. Opera is not usable anymore. It constantly freezes. On my native devices the bug does not appear.

  • @thomas-rager I agree that Opera is not useable in its current state. I have reverted to Firefox, again, which is a shame because the inbuilt Opera VPN service is brilliant.

  • @thomas-rager said in Opera lock up randomly every 5 to 10 seconds (66.0.3515.27):

    I have the same problem under VirtualBox

    Today I searched the VirtualBox bugtracker for my - as I guess - related problem, because VB throws an exception and kills the running machine (Host Win10, guest Solus), whenever I close Opera. Sometimes even when I close a tab, but I've had no Opera lags with my current settings that time.

    I found something with a suggested workaround (to avoid the crashes) that told me to disable the checkbox in the VB settings which switches the 3D support on. So I did.

    Result: no more crashes, but the annoying lags again.


  • @robomike

    I tried to disable hardware acceleration. I did this in VirtualBox and also tried the Opera setting. Did not fix my problem.
    I think the problem is related to this sandbox issue...