Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

When using the system's dark theme, Opera becomes problematic

  • I'm using Seamonkey for most browsing as the dropdowns are just to hard to see.

    Please put in some REAL themes that we can use, I don't consider wallpaper themes, I consider them pictures for background.

  • This Dark Theme problem has existed for over a year while using UBUNTU. I am currently using Ubuntu 17.04. I used to use Opera as my primary browser but the illegible text issue put me off so I quit using Opera about a year ago. I am now back because I love the speed of the browser and its simple design and I was hoping that the issue had been fixed, but it hasn't. Really, it's just a question of putting dark backgrounds in the small text boxes, something that has just been overlooked. Please fix this simple problem so that the browser is usable and I will continue to use it.

  • @ag7878
    No, nothing new. This bug and the compositing one first appeared when opera 45 entered developer, which was on early March. It is mid-May, opera 45 has passed though beta, reached stable and the 2 bugs are still there. Plus, they remain unfixed even on opera 46 (on developer and beta today), which means that in case they fix them, they will appear on opera 47!

  • The same here. Opera with Numix (or any other dark one) system theme is unusable. Have to launch it with
    env GTK2_RC_FILES=/usr/share/themes/Adwaita/gtk-2.0/gtkrc
    to make texts in menu readable.
    The program window generally behaves weird (maybe because of the compositing issue), e.g. it's impossible to take a region screenshot with the menu open.
    On top of all these, strange thing happens with the red "O" logo when enabling sidebar:
    http://en.zimagez.com/zimage/screenshot2017-05-2000-38-05.php
    Overall, Linux version of the browser feels quite unpolished and not really ready to be labelled "stable".
    P.S: Many years ago I was taking part in the discussion regarding UIQ support, which has been dropped eventually. Now it seems that Opera is not really bothered with Linux support either, for the same issues travel from build to build. I really love using the Opera Browser, but such attitude from devs is unpleasant.

  • i am on ubuntu 16.04 using unity an i can confirm that opera(45.0.2552.812) takes gtk2 theme settings instead of gtk3. i am not so much into gtk or themes at all but i worked around this by using gtk2 definitions in my dark theme (vivacious-unity-zfusion) from a corresponding light theme.

    i replaced original "dark" definition in my themes gtk2 gtkrc file with:

    style "dark"
    {
    bg[NORMAL] = "#DFDFDF"
    bg[PRELIGHT] = shade (1.05, "#DFDFDF")
    bg[SELECTED] = @selected_bg_color
    bg[ACTIVE] = shade (0.95, "#DFDFDF")
    bg[INSENSITIVE] = "#DFDFDF"
    }

  • Opera IS supposed to follow gtks's theme since it IS a gtk2 app! The same applies for other gtk2 apps, like ff, chromium, tb, gimp and many more apps that are still made with the gtk2 toolkit. If you check their dependencies, you will notice they all depend on libgtk2.0.

    I use numix as gkt2 and gtk3 theme and the problem is still there. Why?
    Because opera decides to follow the theme's colors for the selected menu entry and its background, but not for the rest (unselected menu entries and their background). And that is exactly what you see on the screenshots above. Obviously, I do not plan "hacking" a great theme like numix in order to change the looks of ONE app that all of a sudden decided to have a "unique look".

  • of course it is a bug which will hopefully be fixed soon. the background color of the context menu seem to be the only problem in my mind. assuming it would be dark, following dark themes, the rest of the colors (selected,enabled, disabled items) would fit to the theme. i was not aware of which apps use gtk3 and which ones gtk2 therefore i was little be confused about opera using theme settings for gtk2.

  • Finally, the compositing and the dark theme bug are fixed in today's opera developer release!

    http://i.imgur.com/IcYnjbY.png

    Well, in all fairness, it is sad that the bugs had to reach opera stable and affect more users and then "force" the devs to issue a fix.

  • After the last update, the menu is shown correctly and the compositing problem was solved in Opera Developer.

    When this updates are made on Stable, this topic can be marked as solved.

    Thank you.

  • I use opera 45 stable with dark theme in ubuntu 16.04 and the menu is illegible (very clear) how do I do the update that fixes the bug? Or does the fix exist only for opera developer?

  • The bug first appeared when 45 made it to opera developer on early March, but the devs did not fix it until 45 reached stable, thus was available to many more users and received lots of complains.

    It was fixed just yesterday on opera developer, so you have 2 choices if the bug affects you too much: either wait until 46 reaches opera stable, or install opera developer today.

  • The fix was ported to opera beta which was released yesterday, so now we all wait to either be ported to stable as well or 46 to reach stable.

    http://i.imgur.com/gLyGi9X.png

  • I have to ask this...
    How many of you have switched from opera stable to opera beta or opera developer now that the bug is finally fixed?

  • Omg! The fix was ported to opera stable earlier! The screenshot is from my non-stock opera-stable (I keep opera-beta and opera-developer stock).

    Well done to the devs!

    http://i.imgur.com/YNjNAkW.png

  • So build 46.2602, which I gather fixes this problem, now requires GKT-3, while any of the previous builds (I was using 46.2556) was perfectly happy to work with just GTK-2. I think this is bad. The new, higher requirements cut off from opera all Linux distros that don't include native GTK-3. Those are mostly the minimalistic distros (minimalistic not in the sense of "very few users" but rather "low system resource needs"). Is there a possibility to go back to GTK2 in a future build?

    # objdump -p opera-developer  46.2556 vs 46.6202  diff
    
    <   NEEDED               libgtk-x11-2.0.so.0
    <   NEEDED               libgdk-x11-2.0.so.0
    ---
    >   NEEDED               libcairo.so.2
    >   NEEDED               libgtk-3.so.0
    >   NEEDED               libgdk-3.so.0
    
  • (re-posting because the previous post is badly formatted)

    So build 46.2602, which I gather fixes this problem, now requires GKT-3, while any of the previous builds (I was using 46.2556) was perfectly happy to work with just GTK-2. I think this is bad. The new, higher requirements cut off from opera all Linux distros that don't include native GTK-3. Those are mostly the minimalistic distros (minimalistic not in the sense of "very few users" but rather "low system resource needs"). Is there a possibility to go back to GTK2 in a future build?

    objdump -p opera-developer 46.2556 vs 46.6202 diff
    
    2556   NEEDED               libgtk-x11-2.0.so.0
    2556   NEEDED               libgdk-x11-2.0.so.0
    
    2602   NEEDED               libcairo.so.2
    2602   NEEDED               libgtk-3.so.0
    2602   NEEDED               libgdk-3.so.0
  • Above information submitted as DNAWIZ-16093.

  • May I ask what distro are you on? Most gtk2 apps slowly move to gtk3 nowadays...

    Btw, opera-beta seems to depend on gtk3 as well

    $ apt-cache depends opera-beta | grep gtk
    Depends: libgtk-3-0
  • I'm on Puppy Linux, one of its many variants.

  • Not all of the Dark Theme problems were solved. Apparently, there are some parts of the interface which have nearly invisible text. The easiest example is to open a notification, where it will be seen the nearly invisible text. This is happening both with Opera Stable and Opera Developer.

    Stable:

    Alt text

    Developer:

    Alt text

    Apparently, there are still some theme-dependent text. As parts of the interface are theme-agnostic, some combinations are causing this issue. On the notifications regarding the battery, this problem appears too.