New Opera Forums launching soon!
Discussion thread

youtube: your browser does not currently recognize any of the video formats available

joeb
joeb

2 posts

    how do I fix this? All I have been able to find is some link that shows how to enable the "disable html5 in youtube" extension (which doesn't make sense to me) and still doesn't work.

    I've been just quitting opera and loading chrome but this is getting irritating. Is this a defect in Opera or is google just being an d%#k?

    10 Replies - 713 Views

    catmcfarlane
    0 0
    Palette

    9 posts

      I just hit a problem today where only the video (blacked out) shows on Youtube's page ... already had YouTube™ Flash-HTML5 extension installed. Checked settings, refreshed page, and that seems to have fixed things. Still speed dial problems (Mint 18.1 Cinammon) though; flicker/vanish according to size, and difficult to use, but at the moment the HTML5 extension has fixed the YT issue. Lots of big companies changing things over in the next few weeks, so there seem to be a lot of glitches going on.

      catmcfarlane
      0 0
      Palette

      9 posts

        Other extensions broken by using HTML5 version, though.

        jimunderscorep
        0 0
        jimunderscorep

        127 posts

          Blame opera's poor html5 support for that and, if you are on a distro that packages chromium-codecs-ffmpeg, install them to get better html5 support.

          joeb
          0 0
          joeb

          2 posts

            same problem.. no solution other than run chrome when going to youtube. Tried installing the chromium codecs, installing some disable html5 extension, no help.

            only working solution is to use any other browser to visit youtube.

            rymar
            0 0
            rymar

            3 posts

              Frustrating that this problem with Opera is still here. I use Opera because in every other sense it's a really good browser but this constantly not being able to play H264 videos is starting to really annoy me. Until this is finally addressed I'm going to stop using Opera...sigh (Linux Mint 18.2)

              sgunhouse
              0 0
              sgunhouse

              3875 posts

              • Moderator
              • Server monkey
              • 2000 posts

              Look for a package of chromium codecs to install in your repository.

              denisftw
              0 0
              denisftw

              8 posts

                I suspect that everyone already has the "chromium-codecs-ffmpeg-extra" package installed. The problem is likely to be a compatibility issue.

                jgffopera
                0 0
                Earth

                17 posts

                  The solution (unfortunately) is to wait for the next update to the Opera browser.

                  adasiko
                  0 0
                  Dog

                  49 posts

                  • Server monkey

                  I suspect that everyone already has the "chromium-codecs-ffmpeg-extra" package installed. The problem is likely to be a compatibility issue.

                  Yes, it is.

                  Ubuntu 16.04:

                  Opera 47.0.2631.80 (based on Chromium 60.0.3112.90)

                  chromium-codecs-ffmpeg-extra: 61.0.3163.79

                  denisftw
                  1 0
                  denisftw

                  8 posts

                    The problem disappeared after replacing libffmpeg.so as described here:

                    https://forums.opera.com/discussion/comment/15271436#Comment_15271436