New Opera Forums launching soon!
Discussion thread

No VPN function

kshar
kshar

4 posts

    Hello

    I downloaded Opera for Mac and tried to use the VPN function, however, the option is not present in the settings menu Previously I used this version of Opera in China where VPN is not available. How can I make it available again?

    6 Replies - 182 Views

    matteols
    1 0
    matteols

    2 posts

      Try clicking on show advanced settings or go to private mode, you should see the option once there.

      kshar
      0 0
      kshar

      4 posts

        Try clicking on show advanced settings or go to private mode, you should see the option once there.

        Problem is, my Opera version considers itself to be a Chinese version, even the start menu has Chinese websites for some reason. How do I change my region?

        avl
        0 0
        avl

        426 posts

        • Opera employee
        • Moderator

        Hi @kshar,

        Try moving away your local state file, which saves, amongst other things, your region. Do this:

        • Make sure Opera isn't running
        • Open Terminal.app
        • Enter on the terminal

          mv ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State\ ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State.backup

        • Start Opera

        kshar
        0 0
        kshar

        4 posts

          Hi @kshar, Try moving away your local state file, which saves, amongst other things, your region. Do this:

          Make sure Opera isn't running Open Terminal.app Enter on the terminal mv ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State\ ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State.backup Start Opera

          Hello, using this command gives a prompt that there is no such directory

          avl
          0 0
          avl

          426 posts

          • Opera employee
          • Moderator

          Yeah, the formatting was messed up. Try again:

          mv ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State\
          ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State.backup
          
          kshar
          0 0
          kshar

          4 posts

            Yeah, the formatting was messed up. Try again: mv ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State\ ~/Library/Application\ Support/com.operasoftware.Opera/Local\ State.backup

            Hello, I tried multiple times and this does nothing, only change is that my quick start menu now shows Chinese websites