Forums are closed as read-only due to our ongoing migration to the new forums page.
Discussion thread

Problems with videos on youtube

bartilan
bartilan

3 posts

    Hey, I really want to use this browser as my daily, but I just can't stand the issues with youtube players. Some videos play ok, but some doesn't, I was searching for solution to this problem, but I can't find. Can you please help me?

    34 Replies - 4367 Views

    barryed
    2 0
    barryed

    6 posts

      Same here - installed Opera today, as I have done from time to time over the past ten years, only to find that NO YouTube vids will play. Love the VPN Opera now has, but this is a major flaw. Seems there's always something that keeps Opera from being my browser of choice.

      kmielczarczyk
      0 0
      kmielczarczyk

      110 posts

      • Moderator

      Hi, what version of OS X are you using? No videos work? What's the error message?

      michaldud
      0 0
      michaldud

      4 posts

        In my case: newest stable opera, newest El Capitan error like that: http://imgur.com/aqcUUwy It's happening for a long time in v40, since Opera Developer (that's reason why I had stopped using it, thought final release will fix it).

        EDIT: And console: http://imgur.com/H0b9XpT

        kmielczarczyk
        0 0
        kmielczarczyk

        110 posts

        • Moderator

        Could you give me an example of a video that does not work?

        barryed
        0 0
        barryed

        6 posts

          Here's the Opera Twitter account, viewed in Opera: http://imgur.com/a/2SkvW

          El Capitan 10.11.5 Opera 40.0.2308.62

          bartilan
          2 0
          bartilan

          3 posts

            Hey, sorry for late response. I'm currently using Mac OS Sierra, but on the previous version was the same issue, so I don't think the problem is in the system version.

            barryed
            0 0
            barryed

            6 posts

              Here's a Youtube video that my Opera browser can't play: http://imgur.com/a/ZpqV1

              michaldud
              0 0
              michaldud

              4 posts

                bartilan
                0 0
                bartilan

                3 posts

                  Here's mine example: https://youtu.be/pFt6rRFSwJM

                  michaldud
                  0 0
                  michaldud

                  4 posts

                    Update to 40.0.2308.62 didn't solve it.

                    garyyarus
                    0 0
                    garyyarus

                    1 posts

                      Same here - installed Opera today, as I have done from time to time over the past ten years, only to find that NO YouTube vids will play. Love the VPN Opera now has, but this is a major flaw. Seems there's always something that keeps Opera from being my browser of choice.

                      I share what you like about Opera. Your experience with videos is similar to what I am experiencing in Twitter. This problem is keeping me from going to Opera full-time.

                      barryed
                      0 0
                      barryed

                      6 posts

                        The ones I flagged are working now, as is bartilan's. Still no videos work on Twitter, including the ones posted by @Opera! ("This browser does not support video playback" LOL).

                        The place to report bugs (desktop): https://bugs.opera.com/wizard/desktop

                        nostromo1965
                        0 0
                        nostromo1965

                        5 posts

                          I opened every one of those YouTube links and was able to watch each video (I'm using the latest version of Opera on macOS Sierra).

                          The trick is to first download the video to your hard drive and watch it there. If I tried to play those videos listed above inside the browser I got the same errors you all were seeing. But if I downloaded the video first, it played just fine.

                          If you install the "Video Downloader All In One" extension (http://addoncrop.com/video_downloader_all_in_one/), then go to the YouTube video page, an additional green Download button will appear just below it. Click it, and it will download it to your hard drive and it will play just fine.

                          Hope this helps!

                          Dan

                          avneto
                          0 0
                          avneto

                          7 posts

                            Any tip on making youtube really fullscreen? It's not working neither on Twitch nor YT.

                            Thank you.

                            barryed
                            0 0
                            barryed

                            6 posts

                              nostromo1965 thanks for the tip. However, the point remains that the browser is broken if it can't play videos.

                              oskarspiano
                              0 0
                              oskarspiano

                              13 posts

                                i had issues with my opera browser on my mac. but i just fixed them simply by opening <opera://gpu> then at the very top "Graphics Feature Status" i used to have "Rasterization" and "Video Decode" in "Software only. Hardware acceleration disabled" mode, which caused many problems with Youtube html5 player as well as several other problems.

                                The solution is to go to <opera://flags> and in search bar type the specific category of "Graphics Feature Status" (in my case "Rasterization" for example). Since this is to do with GPU, i enabled "GPU rasterization" and right away under "Graphics Feature Status" , in <opera://gpu>, next to "Rasterization" appeared a green "Hardware accelerated" sign.

                                I did the same with "Video Encode". Literally the same and now i DON'T have to wait couple of hours to see an uploaded video in Youtube in html5, I can watch Youtube streams (also html5). I am not so much into twitter or vine, but i think this fixed ALL my video playback issues in opera. You are Welcome.

                                vultux
                                0 0
                                vultux

                                3 posts

                                  i had issues with my opera browser on my mac. but i just fixed them simply by opening <opera://gpu> then at the very top "Graphics Feature Status" i used to have "Rasterization" and "Video Decode" in "Software only. Hardware acceleration disabled" mode, which caused many problems with Youtube html5 player as well as several other problems. The solution is to go to <opera://flags> and in search bar type the specific category of "Graphics Feature Status" (in my case "Rasterization" for example). Since this is to do with GPU, i enabled "GPU rasterization" and right away under "Graphics Feature Status" , in <opera://gpu>, next to "Rasterization" appeared a green "Hardware accelerated" sign. I did the same with "Video Encode". Literally the same and now i DON'T have to wait couple of hours to see an uploaded video in Youtube in html5, I can watch Youtube streams (also html5). I am not so much into twitter or vine, but i think this fixed ALL my video playback issues in opera. You are Welcome.

                                  I tried your suggestion but still doesn't work.

                                  Here a link to test. https://gaming.youtube.com/watch?v=q3kS0oILtjc

                                  Every 3 videos that I tried at least one have this problem.

                                  pf4711
                                  0 0
                                  pf4711

                                  2 posts

                                    I also recently stopped being able to open youtube videos with opera...

                                    avl
                                    1 0
                                    avl

                                    426 posts

                                    • Opera employee
                                    • Moderator

                                    Hi all, whether you can see these videos or not depends on the graphics adapter used in your Mac (this is why some people can see the videos and others can't, using the same version of Opera and the same version of macOS).

                                    On Macs that have graphics cards that can't be used for hardware-accelerated video decoding by Opera, Opera's stable version currently doesn't support playing back MSE/DASH videos ( https://en.wikipedia.org/wiki/DynamicAdaptiveStreamingoverHTTP ). These videos are used on Twitter, and in many cases on YouTube (especially for streaming videos).

                                    The current developer edition of Opera (where we test experimental features and new stuff) includes a software video decoder for these cases. If you have this problem, please download Opera Developer from http://www.opera.com/blogs/desktop/ and let us know if this works for you. This feature will become available in Opera's stable version after testing and when we're sure it works as expected.

                                    carlosync
                                    0 0
                                    carlosync

                                    4 posts

                                      I have the same problem of colleagues on some sites is even in the Youtube video is not open at all, when the message was an error try again. I auditioned with Opera Developer 42 and that was solved this problem with videos.

                                      I hope that the company makes available a faster update possible because it is affecting the use of the browser which by the way is very good taking this problem.

                                      Site: https://tecnoblog.net/202126/perigo-anuncios-maliciosos/ Site: https://cursos7.com.br/restaurando-um-site-wordpress/

                                      https://snag.gy/xW7qfj.jpg

                                      System: macOs Sierra 10.12 Opera: 40.0.2308.8

                                      avl
                                      0 0
                                      avl

                                      426 posts

                                      • Opera employee
                                      • Moderator

                                      I have the same problem of colleagues on some sites is even in the Youtube video is not open at all, when the message was an error try again. I auditioned with Opera Developer 42 and that was solved this problem with videos.

                                      The feature will also be available in Opera 41, currently in beta. This will become the next stable version Very Soon. Sorry for keeping you waiting, just have to exercise your patience a little more now ;)

                                      michaldud
                                      0 0
                                      michaldud

                                      4 posts

                                        Today's update, problem still exists. Come on, how long should we wait for fix?

                                        carlosync
                                        0 0
                                        carlosync

                                        4 posts

                                          ok, waiting for the new version

                                          iojananpenia
                                          0 0
                                          iojananpenia

                                          1 posts

                                            Hi: i am new in the foro. What can i do to watch ARTE Chanel ?

                                            rrcwb
                                            0 0
                                            rrcwb

                                            1 posts

                                              I have the same problem in macOS Sierra.

                                              [Deleted User]
                                              0 0
                                              [Deleted User]

                                              0 posts

                                                Does this problem have anything to do with updating to the latest Adobe Flash Player? Just wondering.

                                                frisyren
                                                0 0
                                                frisyren

                                                1 posts

                                                  Hi all, whether you can see these videos or not depends on the graphics adapter used in your Mac (this is why some people can see the videos and others can't, using the same version of Opera and the same version of macOS). On Macs that have graphics cards that can't be used for hardware-accelerated video decoding by Opera, Opera's stable version currently doesn't support playing back MSE/DASH videos ( https://en.wikipedia.org/wiki/DynamicAdaptiveStreamingoverHTTP ). These videos are used on Twitter, and in many cases on YouTube (especially for streaming videos). The current developer edition of Opera (where we test experimental features and new stuff) includes a software video decoder for these cases. If you have this problem, please download Opera Developer from http://www.opera.com/blogs/desktop/ and let us know if this works for you. This feature will become available in Opera's stable version after testing and when we're sure it works as expected.

                                                  Wow. I was on my way to give up Opera due to those video problems - Opera Beta 41 seem to solve all my issues. yihaaaooo

                                                  avl
                                                  1 0
                                                  avl

                                                  426 posts

                                                  • Opera employee
                                                  • Moderator

                                                  Opera 41 stable was released today. Update update update! :)

                                                  vultux
                                                  0 0
                                                  vultux

                                                  3 posts

                                                    YES!!! YES!!! YES!!!!!!!!!!!!!!

                                                    The problem with YT videos was fixed!!! (at least on the videos that I tested)

                                                    Now I can use Opera everyday!

                                                    Thank you guys and girls!

                                                    carlosync
                                                    0 0
                                                    carlosync

                                                    4 posts

                                                      problem in the videos has been solved, thanks guys..

                                                      xac69
                                                      0 0
                                                      xac69

                                                      1 posts

                                                        Still issues with youtube videos!!! Opera version 45.0.2552.812 on Mac OS X 10.12.5 64-bit Example:

                                                        U9GV4Jw
                                                        concretable
                                                        0 0
                                                        concretable

                                                        264 posts

                                                          two examples: https://youtu.be/ikqbyjbKAPY https://youtu.be/415XR5mye3E

                                                          The first one says, "This video is unavailable" but the second one works for me.

                                                          furrynutz
                                                          0 0
                                                          furrynutz

                                                          14 posts

                                                          • Server monkey

                                                          "This video is unavailable" means that YT or the user removed video from access from the public.

                                                          alicarusu
                                                          0 0
                                                          alicarusu

                                                          1 posts

                                                            -