New Opera Forums launching soon!
Discussion thread

[Solved]45.0.2545.0 why depending compositing?

alexs
alexs

20 posts

    With today developer build, i have on all menus a big ugly black border. I have and i will not enable Compiz, never!

    Opera have option for Power saving mode/Battery saver, why i must enable the eye candy compositing? Please add this as option (opera://flags), for me this is unacceptable.

    45.0.2545.0 right click menu

    Second: On the right click menu on website the German word ›Über%tragen‹ (Inspect element) is wrong. Correct: ›Übertragen‹

    OS: NVIDIA G94, Siduction x86_64 (based on Debian/sid) /Xfce

    32 Replies - 1001 Views

    alexs
    0 0
    alexs

    20 posts

      Edit: I mean ›Übertragen‹ (German) ›Cast‹ (English)

      kmielczarczyk
      0 0
      kmielczarczyk

      110 posts

      • Moderator

      We were able to reproduce this only ones when running Opera for the first time. Then it was displayed properly. Maybe it's some site specific issue?

      alexs
      1 0
      alexs

      20 posts

        We were able to reproduce this only ones when running Opera for the first time. Then it was displayed properly. Maybe it's some site specific issue?

        It's only a problem when disable compositing (for me Compiz under Xfce). I have testing with clean Profile. Opera Compiz bug

        see the edit on the Dev Blog from user L33t4opera

        alexs
        0 0
        alexs

        20 posts

          Cannot more folks reproduce this issue?

          alexs
          0 0
          alexs

          20 posts

            Same with build 45.0.2548.0

            I file bug report DNAWIZ-13537

            furret29
            1 0
            furret29

            16 posts

              I can confirm this.

              Opera 45.0.2548.0, using XFCE on Ubuntu 16.04.2 LTS. I don't use compiz, it is the composition of the own xfwm4, which can be adjusted using window manager settings. The black borders appears with composition disabled.

              With composition enabled:

              Alt text

              With composition disabled:

              Alt text

              The dark theme bug deserves another post, I believe.

              I have tested Opera 45.0.2548.0 on another system, this one with Ubuntu 16.04.2 LTS, LXDE, using openbox with no composition. It has the black borders too.

              surf-ing
              0 0
              surf-ing

              8 posts

                I can confirm this bug. GNU/Linux 64 box with OpenBox window manager and no video compositing manager (not even installed, will not install a compositing manager).

                alexs
                0 0
                alexs

                20 posts

                  Same with build 46.0.2556.0 …

                  rrzepecki
                  0 0
                  rrzepecki

                  71 posts

                  • Opera employee
                  • Moderator

                  hey, the problem with the menu is another known bug, so we will be fixing it.

                  alexs
                  0 0
                  alexs

                  20 posts

                    hey, the problem with the menu is another known bug, so we will be fixing it.

                    I hope, the build 46.0.2573.0 is the fifth dev build with the regression bug…

                    I downgrade again to 45.0.2539.0

                    jimunderscorep
                    0 1
                    jimunderscorep

                    127 posts

                      Please do something about it. I was on opera developer until it reached version 45 and compositing messed up the menus. Then I moved to opera beta which was on version 44. When opera beta was updated to version 45 and the compositing problem was not solved, I moved to opera stable whuch is on version 44 now.

                      If the problem exists by the time version 45 reaches stable, I will move to another browser.

                      Debian testing x64 with openbox and with no compositing.

                      jimunderscorep
                      0 1
                      jimunderscorep

                      127 posts

                        Opera 45 has reached rc today and neither the compositing problem, nor the dark theme problem* are solved yet, so I guess I should start looking for a new browser...

                        alexs
                        0 1
                        alexs

                        20 posts

                          Yes, I also believe that it will be time for me to change to Vivaldi. The Opera Devs ignore this bug and this is also in the current Opera-Beta (45.0.2552.634) inside the soon to change stable.

                          I have spent a long time (since Opera 6.06) with Opera, it's time to go.

                          jimunderscorep
                          0 0
                          jimunderscorep

                          127 posts

                            I won't switch to vivaldi though. I really hate nodejs-based (or electron) apps. I may switch to qupzilla. It has switched to chromium engine since version 2, it has opera's 12.x speed dial, built in adblock and it looks quite promising :)

                            jimunderscorep
                            0 1
                            jimunderscorep

                            127 posts

                              Opera 45 reached stable a few minutes ago and neither the dark theme bug, nor the compositing one was solved. Goodbye opera.

                              e51ja
                              0 0
                              e51ja

                              6 posts

                                Same here with mate and mint 18.1 with disabled compositing:

                                https://forums.opera.com/discussion/1883807/black-border-around-context-menus

                                nup66
                                0 0
                                nup66

                                1 posts

                                  i have on all menus a big ugly black border on lubuntu 16.04 please help mi

                                  knokmki612
                                  0 0
                                  knokmki612

                                  20 posts

                                    I simply installed xcompmgr to solve this matter

                                    e51ja
                                    1 0
                                    e51ja

                                    6 posts

                                      @knokmki612: compositing decrease performance on some pc ;)

                                      pvozerski2
                                      0 0
                                      pvozerski2

                                      1 posts

                                        I confirm the "ugly border" bug on LMDE 2 with Trinity DE R14.0.4 installed.

                                        pescie
                                        0 0
                                        pescie

                                        2 posts

                                          I confirm the bug on Xubuntu

                                          maxymku
                                          0 0
                                          maxymku

                                          6 posts

                                            opera://flags/ => Override software rendering list (enable it).

                                            maxymku
                                            0 0
                                            maxymku

                                            6 posts

                                              Other method: opera://settings/ => Browser => System => disable "Use hardware acceleration when available".

                                              alexs
                                              0 0
                                              alexs

                                              20 posts

                                                @maxymku

                                                opera://flags/?search=overr#ignore-gpu-blacklist and the another preferences does not help.

                                                Only enable the compositing manager…

                                                maxymku
                                                0 0
                                                maxymku

                                                6 posts

                                                  @maxymku opera://flags/?search=overr#ignore-gpu-blacklist and the another preferences does not help. Only enable the compositing manager…

                                                  Both methods solve the effect of "big ugly black border" in my system (Slackware 14.0, x86).

                                                  parkmino
                                                  0 0
                                                  parkmino

                                                  1 posts


                                                    @maxymku opera://flags/?search=overr#ignore-gpu-blacklist and the another preferences does not help. Only enable the compositing manager…

                                                    Both methods solve the effect of "big ugly black border" in my system (Slackware 14.0, x86).

                                                    This workaround does not apply to lubuntu 16.04 amd64

                                                    jimunderscorep
                                                    0 0
                                                    jimunderscorep

                                                    127 posts

                                                      None of these workarounds worked for me as well (debian testing x64, openbox, no compositing manager, opera 45 stable).

                                                      Since the lazy maintainers of my disto have not yet packaged qupzilla 2.1.x, I am back to opera. And reopened my account here, because deleting it would also delete my comments :(

                                                      jskier
                                                      0 0
                                                      jskier

                                                      2 posts

                                                        Also present on Arch Linux. Have tested Intel, AMD, and Nvidia gpu; if compositing is off these borders show up.

                                                        https://bugs.archlinux.org/task/54005?project=5&cat[0]=33&string=opera

                                                        jimunderscorep
                                                        1 0
                                                        jimunderscorep

                                                        127 posts

                                                          The compositing bug was solved today in the latest opera-developer version, along with the dark theme one.

                                                          http://i.imgur.com/IcYnjbY.png

                                                          jskier
                                                          0 0
                                                          jskier

                                                          2 posts

                                                            The compositing bug was solved today in the latest opera-developer version, along with the dark theme one. http://i.imgur.com/IcYnjbY.png

                                                            Thanks for the heads up, 2602 appears to work for me without the black borders as well (xfce4, no compositing).

                                                            alexs
                                                            0 0
                                                            alexs

                                                            20 posts

                                                              The bug is fixed on Opera developer build 46.0.2602.0, thanks.

                                                              (Debian/sid with xfce, without compositing)

                                                              But with Opera dark theme, the background and color from the tooltips *) is bright.

                                                              *) Button on main bar, tabs on tab bar, bookmarks on bookmarks bar

                                                              jimunderscorep
                                                              0 0
                                                              jimunderscorep

                                                              127 posts

                                                                Well, I have the same issue on opera stable. It seems that the light and dark built in themes only change the address bar and the tab bar and nothing more. Even the recently closed tabs menu uses the light theme!

                                                                Obviously, it is not related to the dark gtk theme bug. This was solved by forcing opera to use some gtk theme they have made (light grey menus, darker grey selected entries and black letters).

                                                                This discussion has been closed.