The video in the link you mentioned works fine for me in Opera and Windows 10.

Hmm, download the Opera installer, launch it, click "options", set "install path" to a folder on your desktop, set "install for" to "standalone installation" and install. Don't enable Opera Sync or add any extensions to that Opera. Does it work fine there?

If not, try disabling hardware acceleration. If that doesn't work, reenable hardware acceleration and goto chrome://flags/#ignore-gpu-blacklist to override the gpu blacklist just to see if it makes any difference. If that doesn't work reset the flag back to default and try this.

What does https://www.youtube.com/html5 report?

What OS and what GPU are you using?