You need to update to Android 5.1 at least.