Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera
  • Why is it that Firefox and Konqueror will play mp3 files, but the Opera plug-in crashes? Konqueror will open with any of the 5 players I have available: KMPlayer, Audacity, VLC, Kaffeine, or Amarok - just right-click the file, and choose. Firefox is using KMPlayer, but I think it was using VLC before I started trying to fix Opera's plug-ins. I'm using Opera 12.16 in MEPIS OS, which is Debian based.

    I found Opera's "simple" instructions for adding or fixing plug-ins at:
    and I think I followed them. I have this as my ~/.opera/pluginpath.ini

    Opera Preferences version 2.1
    ; Do not edit this file while Opera is running
    ; This file is stored in UTF-8 encoding


    I have these plug-ins at /usr/lib/opera/plugins :, and
    Plus there are other plug-ins at /usr/lib/mozilla/plugins.

    So why does it crash? Does it have too many options and can't sort them out, or is it "afraid" of the proprietary aspects of mp3? Or is my Opera broken? What's wrong? I hate it when I have to go to a different browser.

  • libvlcplugin (vlc 2.0.6-dmo3 from works fine on Debian 7.8 (x64) with Opera 12.16 on MP3 stream and testfile toddle.mp3

  • Thank you, gwen-dragon, for that verification that Opera 12.16 DOES play mp3. Just in case my "OPera" was broken, I re-installed it. The plugin for mp3 files still crashes. The re-install didn't seem to make any difference to the ~/.opera/pluginpath.ini file.

    This is sure a puzzle to me. I don't see how it could be a fault with MEPIS, since every other program will play the mp3 files. Frustrating!

  • Strange, which plugin is used from Opera 12 on your OS?

  • gwen-dragon said: Strange, which plugin is used from Opera 12 on your OS?

    I don't know! As I said in my first post, the same plugins exist in various places. For example, is also located at /usr/lib/mozilla and /usr/lib/mozilla-firefox. How do you determine which plugin is being used?

    1. open URL opera:plugins
    2. decativate all plugins
    3. step by step activate only one audio/video plugin
    4. load MP3 in Opera
    5. goto step 3.

    There must be one plugin which crashes Opera.

  • Isn't there an easier way? Which plugin is listed for that type in Preferences > Advanced > Downloads?

  • Wow! Thanks for the education, gwen-dragon and sgunhouse! I didn't know that "about:plugins" existed. I still need more education about what MIME type has to do with access to plugins. I will respond to gwen-dragon's question first.

    In the first place, I have 8 plugins, and these are the results: VLC Multimedia Plug-in ( (twice) (both plugins crash), Kaffeine Starter Plugin ( (twice) (both of these work, but the "seek slider" is inoperative, making the app useless), Shockwave Flash ( (Not Applicable), Skype Buttons for Kopete ( (Not Applicable), Plug-in ( (Not Applicable), Shockwave Flash ( (Not Applicable).

    One thing that really seems strange to me is that Firefox doesn't use the VLC plugin, even though in Synaptic the plugin is called "mozilla-plugin-vlc"! That version is "1.1.3-1squeeze6"--I wonder if that is too old for either Opera or Firefox to accept!? Also, when I do a Firefox search for the VLC plugin, it gives me a jungle of plugins, but very few that appear VLC related. The VLC that I see available for Linux for download is version 2.1.5.

    Next, sgunhouse, you asked about "Which plugin is listed for that type in Preferences > Advanced > Downloads?", Well, in the first place, there is a check mark for "Hide file types opened with Opera". There are a total of 172 items listed! Of these, 7 are blank in the "File Extension(s) column. There are 5 in the mp3 category. Note that 2 of these included other than mp3. The MIME types are: "audio/x-mpeg", "audio/mp3", "audio/mpeg3", "audio/x-mpeg3", and "audio/mpeg". When I removed the check from "Hide file types opened with Opera", at 200 I was about half way through, so I assumed 400 and stopped counting! There were 28 with a blank "File extension(s)", and there were the same 5 in the mp3 category.

    I've noticed some remarks during my Internet searches about the proprietory aspects of mp3. If that's the problem, I wish some one would just let us drop a couple nickles in the slot and let us get on with it. But, of course, that makes no sense, because Knoqueror has no problem, nor do you, gwen-dragon, with Debian 7.8.

    What else do I need to look for? Thanks

  • I seem to recall something about a conflict between some plugins and Opera's desktop integration with GTK+ (with Gnome or XFCE as desktop), changing the dialog toolkit (in opera:config) to 4 and restarting would resolve the conflict at the expense of non-native file dialogs.

    As for mime type, the 5 you mentioned are the ones you'd look at. If you select one and click Edit, you'll get a dialog where you can change how Opera handles that specific type. At the bottom it'll say "Use plug-in" and have a dropdown list of the applicable plug-ins (the ones that say they can handle that type). You can change the plug-in being used there without moving files.

    On my distro, I can choose either a "free" version of VLC which lacks proprietary codecs or a "tainted" version that includes everything available, your distro may call it non-free or some such. But even if the "free" version doesn't play MP3 files, it should only give you an error message and not crash the browser, so I'm leaning towards the toolkit conflict.

  • Thanks again for the information, and forcing me to do some study of MIME type. I should clear up one thing about the "crash". "The browser" (Opera) never crashed, only the "plugin". I think I always said the plugin crashed, but there was one comment about crashing Opera.

    I could not find anything related to "dialog toolkit (in opera:config)", though I looked everywhere that seemed logical, and other menu places. Could you give me a clue about that? I am not, however, using Gnome or XFCE, but rather KDE (on MEPIS).

    After looking at the 5 types in Tools > Preferences > Advanced > Downloads, I realized I needed to find out which type the file is that I was trying to play. I did some searching and found "file -b --mime-type [file-name].mp3". When I ran that on the file, it said it was "audio/mpeg". The "Downloads" window says that will handle "mp3,mp2,mpga,mpega,mpa,abs". There are 2 VLC and 2 kaffeine plugin paths available, and I set it on the "/usr/lib/opera/plugins/" path. With all that, trying to open the file still results in "Plug-in has crashed".

    By the way, I guess it's OK to ref. file I'm looking at. It is at:

    I don't know how to tell if a particular package is "free" or "non-free". The VLC plugin Package is called: "mozilla-plugin-vlc multimedia plugin for web browsers based on VLC", and the Maintainer is shown as "Debian multimedia packages maintainers", and its version is "1.1.3-1squeeze6". I have wondered if this is an old version. I found that VideoLAN has a version 2.1.5 available for Linux, but I guess that's not related to "1.1.3-1" in squeeze6 as a version.

    It sure seems strange to me that Opera won't open it when everything else I have will.

  • Type it into the quick search bar. Or just type Toolkit, it should only appear once. It only appears in Linux - as I'm currently in Windows I can't look it up.

  • Thank you for that explanation--I found Dialog Toolkit. I tried entering "4", and also "3", "2", and "1" (it was defaulted to 0), restarting Opera each time, and it made no difference, the plugin still crashed.

    I also took a look at the new VLC 2.2.0 from VideoLAN, and it seems to be more complex than I want to tackle. My MEPIS 11 is based on debian "squeeze", and VLC 2.2.0 seems to be aimed at "wheezy". This has already caused you and gwen-dragon more trouble than it's worth. I'll just take a couple extra steps and open any mp3 file with Konqueror, and consider that something in Opera or MEPIS is busted, and let it go at that. Thanks very much to both of you!