Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

[Closed by Request]New Opera developer 29

  • Question: Is there a way to start opera with all extensions disabled? Would be useful for problem determination.

  • Hi @hasi68: yes, you can, you need to add the "--disable-extensions" command line switch at the end of the shortcut, which you use to launch the Opera, as follows:

    On Windows: "\path\to\launcher.exe" --disable-extensions

    On Linux: /path/to/opera-develper --disable-extensions

    In case, that you want to check also, whether one of the flags is the culprit or not, you can add the "--no-experiments" switch, as shown below:

    On Windows: "\path\to\launcher.exe" --no-experiments

    On Linux: /path/to/opera-develper --no-experiments

    Small note: you can use both of the above switches at once, just make sure to add a space between them.

  • Hi @l33t4opera: Thanks a lot for your useful tips. I solved the problem with the print preview already. It was my fault, i disabled the internal chrome pdf viewer plugin because I'm using the pdf extension, but the print preview needs the internal pdf viewer.

  • With the latest developer version, I am seeing some (but not all) HTML selects not rendering correctly or rendering as empty.

    Linux/Arch/HiDPI.

  • +1, discretely hinting to this topic

  • New Opera developer 29.0.1794.0, the change log, and the announcement 😉

    ☕ \m/ :cheers:

  • 29.0.1794.0 doesn’t work at all for me. I can open Opera, but no pages, not even speed dial, settings, about, etc. All I get is ”Slut på minne” (Out of memory). Reinstalled with Synaptic, restarted the system. No difference. Two Opera-processes are active: opera-developer and its gpu-process. Ubuntu 14.10 64-bit, 7,5 GiB RAM.

  • Completely uninstalled and installed again, no difference.

    joakim@JoWa:~$ opera-developer
    [0306/200914:ERROR:zygote_host_impl_linux.cc(85)] Trying to restart the zygote/sandbox multiple times in quick succession. Something is probably very wrong, we will will give up.
    [0306/200914:ERROR:url_pattern_set.cc(240)] Invalid url pattern: opera://print/*
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0306/200914:ERROR:child_process_launcher.cc(529)] Failed to launch child process

  • After installing Opera developer 29.0.1794.0 (windows 8.1 32bit) i installed java 8.40 and now java doesn't work at all in the browser. When using the java test page https://www.java.com/en/download/installed.jsp I only get the error message that the page abended (i don't know the exact english text because the message is in german). Same when I try to test java applets. The java installation went well and i can test java successfully in other browsers like firefox.

  • Hi, I solved my java problem: it was caused by the plugin settings: I had not checked " execute all plugins" but "execute important plugins"

  • joakimwallden: When i started opera developer in the terminal just with opera-developer, it works. But when I start with sudo opera-developer, I get exactly the same error that you get; "out of memory"/"slut på minne" (I am from Sweden too). It seems like there is some sort of bug, perhaps we should move this discussion to a thread in the opera for linux category.

  • It’s the other way around for me. Opera works when started with sudo. O.O

  • joakimwallden: Try to change the owner of the files in ~/.config/opera-developer and ~/.cache/opera-developer to you. They could have been set to root.

  • Thanks gustavwiz. Those folders are mine. I uninstalled 29.0.1794.0 and installed 29.0.1788.0. Runs with no problems.

  • Why not just move the tab site on the sidebar (Ctrl Shift C)? In addition Extensions Sidebar add move option.

  • Opera 29.0.1795.0:

    [0311/163836:ERROR:zygote_host_impl_linux.cc(85)] Trying to restart the zygote/sandbox multiple times in quick succession. Something is probably very wrong, we will will give up.
    [0311/163836:ERROR:url_pattern_set.cc(240)] Invalid url pattern: opera://print/*
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:channel.cc(299)] RawChannel read error (connection broken)
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:channel.cc(299)] RawChannel read error (connection broken)
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process
    [0311/163836:ERROR:child_process_launcher.cc(529)] Failed to launch child process

  • New update - Opera developer 29.0.1795.0, the change log, and the announcement.

    ☕ \m/ :cheers:

  • Hi @joakimwallden, and what if you run the opera-developer with the switch as follows: opera-developer --no-sandbox ?

  • Hi l33t4opera. Opera 29.0.1795.0 works with --no-sandbox. (I will not use it without sandbox, though.)

  • @joakimwallden, I'm aware of that, this was just to test, if the problem can be related to the sandbox feature, now please run this command: ls -l /usr/lib/x86_64-linux-gnu/opera-developer/opera_sandbox, and paste here, what it displays.

Log in to reply