Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

Scheduled logout

In order to introduce new security features and enhance your experience with Opera Forums we had to terminate all sessions that were started before Monday, March 25, 15:00 UTC.
If you find yourself logged out please rest assured that this is completely normal and expected. To participate in the discussions after that date you have to sign-in again using the "Login" button.
Apologies for any inconvenience caused.

Keeping Opera the Default Browser

  • This wasn't a problem until yesterday. All of a sudden IE has become my default browser, and going into Opera/Setting/"Make Opera My Default Browser" does absolutely nothing. If I close the settings page and reopen it, Opera is no longer default.

    Anyone have a solution?

    Opera 26.0.1656.60
    Windows 7, 64 bit

  • Were you doing anything within IE just before you noted the default change? Also, did your system happen to perform a 'Windows update' just before the change appeared?

  • Thank you for responding. I almost never use IE, but do when Opera does not display a page properly. There was a Windows update this week, so something about it I suspect caused this problem. But IE cannot be turned off as the default browser now.

  • Because of the possibility that it's an OS/update issue, there are a couple of things to try from that angle. First, if you haven't already done it, power down the computer for a couple of minutes and restart it (just in case something in the update/reboot processes has caused a glitch)... then see if the defaults are sorted out. Next, if things are still messed up, open Windows' Control Panel and select Default Programs > "Set your default programs" > Select Opera and try making it the default program.

Log in to reply