Do more on the web, with a fast and secure browser!

Download Opera browser with:

  • built-in ad blocker
  • battery saver
  • free VPN
Download Opera

HTTPS-Problem bei der Google-Suche

  • Und das soll dann NUR bei Opera stören und bei sonst keinem anderen Browser? Nicht bei Google Chrome, nicht bei Firefox oder Waterfox? Alle mit den gleichen Einstellungen?

    Ich habe zumindest auch schon mal versucht, alle Blocker und Erweiterungen auszuschalten, hat aber auch nichts geändert. Die Windows Firewall und NOD32 werde ich dafür ganz sicher nicht ausschalten, zumal NOD32 sowieso das beste ist.

    Im übrigen fing das Spiel ja erst vor kurzem mit der Version 27.x (ich glaube die vorletzte) an, vorher ging alles gut. Wann hat Google denn diese Komprimierung eingeführt?

  • Und das soll dann NUR bei Opera stören und bei sonst keinem anderen Browser? Nicht bei Google Chrome, nicht bei Firefox oder Waterfox? Alle mit den gleichen Einstellungen?

    Das ist in der Vergangen oft genug genau so aufgetreten, wobei das gestörte Programm nicht immer Opera hieß.

    Die Windows Firewall und NOD32 werde ich dafür ganz sicher nicht ausschalten, zumal NOD32 sowieso das beste ist.

    Wenn du mögliche Fehlerquellen nicht ausschließen willst, so ist das dein Problem. Es spricht ja gar keiner davon die dauerhaft zu deaktivieren. Wobei die Windowsfirewall eher unverdächtig ist und es oft genug nicht genügt, die Sicherheitssoftware zu deaktivieren.

    Im übrigen fing das Spiel ja erst vor kurzem mit der Version 27.x (ich glaube die vorletzte) an, vorher ging alles gut. Wann hat Google denn diese Komprimierung eingeführt?

    Diese Information hätte in den Startbeitrag gehört.

  • Vielleicht hat deine Sicherheitssoftware ein Update inzwischen bekommen, das stört?

    Und das soll dann NUR bei Opera stören und bei sonst keinem anderen Browser?

    Ja, das gabs früher mit Opera und Firewall/AV öfters bei komprimierten Daten.
    Wenn allerdings Opera 26 und Chromium wirklich Software für Netzwerk benutzen sollte es nicht auftreten. Aber woher soll ich das wissen, was Opera da sonst noch reinbaut.

    Im übrigen fing das Spiel ja erst vor kurzem mit der Version 27.x (ich glaube die vorletzte) an, vorher ging alles gut. Wann hat Google denn diese Komprimierung eingeführt?

    Die Kompression gibt es schon länger (seit 2009), Google benutzt es auch seit Jahren. Sollte als den Opera und Chromium-Entwicklern bekannt sein.

  • Ok, ich habe jetzt extra für Euch nochmal alles getestet. Mit neuem Profil, Antivirenprogramm ausgeschaltet und sogar die Windows Firewall deaktiviert. Ebenso alles, was blocken kann, ausgeschaltet, wie zum Beispiel HostsMan.

    Gleiches Ergebnis. Erste Suche nach Neustart funktioniert, weitere Suchen bringen die Fehlermeldung. Nach Leeren des Caches geht es wieder genau einmal, danach wieder Fehlermeldung. Dies sowohl mit SPPDY/4 eingeschaltet als auch ausgeschaltet (Standardeinstellung).

    Dass ich die Version im ersten Beitrag nicht gleich genannt habe liegt daran, dass ich diesen eigentlich direkt an Christoph gerichtet hatte und wir aufgrund des vorangegangenen Plauschs im offiziellen Opera-Blog wussten, worum es geht und welche Version gemeint ist. Wobei ich mir nicht ganz sicher bin, ob Christoph das nicht sogar in einer früheren Version festgestellt hat. Jedenfalls hätte ich es schon früher geschrieben, wenn es da aufgetreten wäre.

    Ich hätte dies ja, falls jetzt Einwände kommen, auch direkt an Christoph per e-Mail geschrieben (was eigentlich auch meine Absicht war), wenn ich wüsste, wie ich einzelne Mitglieder persönlich erreichen kann. In vielen anderen Foren und Gruppen ist es möglich, Teilnehmer entweder anonym über das Forum oder über eine e-Mailadresse direkt anzuschreiben. Im offiziellen Opera-Blog und hier habe ich das nicht gefunden. Kann mich vielleicht jemand erhellen?

  • @ralf-brinkmann

    Ich glaube dir, dass du das Problem hast. Es ist wohl wirklich ein spezielles Problem bei dir. Ich hatte das Problem nie bei Verwendung der Googlesuche als Standardsuche.
    Auf meinem Windows 7 x64 Ultimate (Opera 26 STABLE, Opera 27 BETA oder Opera 28 DEV) senden die Browser immer den Header mit sdch an Google und war die Suche war immer aufrufbar.

    ich tippe immer noch auf irgendwelche Netzwerktreiber von Sicherheitssoftware.
    Aber so richtig können das nur die Opera-leute rausbekommen.

    Im Endeffekt ist es aber ein NoGo, dass Opera da so hakt.

  • Ich war übrigens nicht der Einzige, der das Problem hat. Neben Christoph selbst hat sich mindestens noch ein weiterer User bei mir gemeldet. Und die "Sicherheitssoftware" habe ich ja, wie oben geschrieben, komplett ausgeschaltet. Mehr Sicherheitssoftware habe ich nicht. Windows Firewall, NOD32 Antivirensoftware, HostsMan und im Profil dann noch AdBlock und Ghostery als Erweiterung. Die waren bei einem neuen Profil ja gleich gar nicht mehr vorhanden.

    Was meinst Du mit "senden die Browser immer den Header mit sich an Google"? Welchen Header? Hat das was mit der benutzten User-Agent-Kennung zu tun?

    Übrigens habe ich das gleiche Problem auch, wenn ich meinen eigenen Suchstring (noch aus Zeiten von 12.x) verwende:

    http://www.google.com/search?q=%s&{google:sourceId}ie=utf-8&oe=utf-8&channel=suggest&num=100&as_qdr=all

    Da steht zwar http, aber Google oder Opera oder der heilige Geist stellt das dann sofort von sich aus auf https um und ich bekomme wieder die gleiche Fehlermeldung.

  • NOD32 hat aber einen Netzwerkfiltertreiber, der ist doch noch installiert, deaktiviert ist nicht ohne Funktion, und dort wird immer noch alles durchgejagt.
    Könnte sein, dass der Probleme macht. Aber das ist nur meine Vermutung.

    Mit dem Header meine ich, dass der Browser den folgenden Header
    Accept-Encoding:gzip, deflate, lzma, sdch
    an Google sendet, um zu zeigen welche Komprimierung er versteht.

  • Wie kann ich denn feststellen, was für ein Header bei mir an Google mitgesendet wird? Dein Hinweis hat mich auf eine Idee gebracht.

  • Ihr könnt euch die Spekulationen sparen, bei mir ist es (soweit ich mich erinnere) in der selben Version aufgetreten (irgendwo Ende 27). Es liegt an Opera.
    Danke für das Testen mit neuem Profil, Ralf. Ich sorge dafür, dass das Problem intern neu priorisiert wird, da es ja offensichtlich auch mit Standardeinstellungen auftritt. :ninja:

  • Moin Christoph! Ja, getestet werden sollte es auf jeden Fall, denn immerhin tritt es mit Google Chrome, das ja eigentlich den gleichen Unterbau verwendet, nicht auf.

    GwenDragons und Meersaus Hinweise haben mich jedoch auf eine Idee gebracht. Ich verwende, wie oben geschrieben, NOD32 als Antivirenprogramm (Du auch?). Da gibt es in den erweiterten Einstellungen den Bereich "Web und e-Mail" => "Web-Schutz" => "HTTP, HTTPS". Dort kann man bei den HTTPS-Prüfungseinstellungen den HTTPS-Filtermodus markieren: "HTTPS-Protokollprüfung nicht verwenden" oder "HTTPS-Protokollprüfung für ausgewählte Ports durchführen". Standardmäßig ist dieser Punkt mit dem voreingetragenen Port 443 aktiviert.

    Wenn ich das ausschalte und die HTTPS-Protokollprüfung deaktiviere, dann tritt der Fehler nicht mehr auf.

    Ob das gut ist oder nicht, kann ich nicht beurteilen, da ich nicht weiß, was genau die SDCH-Erweiterung bewirkt. Ich möchte natürlich ungern einen Teil meiner Sicherheit aufgeben. Und ich weiß auch nicht, warum das einfache Deaktivieren von NOD32 zu Testzwecken anscheinend diese Einstellung nicht aufhebt. Ich dachte, deaktivieren heißt komplett ausschalten.

    Zumindest kann das nun aber bei den weiteren Prüfungen mit einbezogen werden.

    Und vielleicht kann mir doch noch jemand sagen, wie oder wo ich das mit dem an Google übersandten Header nachsehen kann.

  • Nein, ich verwende nur den in Windows 8.1 integrierten Schutz. Allerdings tritt das Problem bei mir ja auch nicht auf, wenn ich SPDY4 deaktiviere. Wahrscheinlich zwei verschiedene Wege, das gleiche Symptom zu sehen...